We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2 - LEDE or OpenWrt?

  • @Pierre-Rossinès said in Omega2 - LEDE or OpenWrt?:

    @luz Thanks. Does LEDE include the firmware flashing tool ? I have no dock nor do I have a serial to USB chip, so I would appreciate to be able to flash the official firmware back if I mess something up while using LEDE.

    Realistically, if you want to do any serious work on embedded systems you'll need to acquire a USB<>logic-level serial converter for 3.3v targets. They cost around $5-6.

    In theory, if you had a perfect new image you wanted to load you could use a web interface or scp and ssh via the sysupgrade method, but should anything go wrong you'll need the serial interface (at minimum) to understand what went wrong.

  • @WereCatf said in Omega2 - LEDE or OpenWrt?:

    @luz said in Omega2 - LEDE or OpenWrt?:
    I tried to tell you, it still wouldn't be identical. .config only tracks configuration-changes that LEDE is aware of, it doesn't track any changes to the actual source-code nor any kernel-config changes outside of the pre-defined ones that LEDE-supports. So no, it still wouldn't be identical, they have made changes that the LEDE configuration-tools are not aware of and thus wouldn't be tracked in .config.

    Which brings us back to an issue that has haunted us since the early days (over 1 year ago) of the Omega1 - without access to the official repository that Onion uses we are still playing catch up and trying to hack things together.

    Despite numerous requests for this, no reply has been forthcoming - not even a We can't because of X Y Z

    A few weeks ago there was discussion on this forum as to whether or not Onion were in breach of the terms of the open source licences on this issue. That discussion kind of petered out with no resolution on it

  • @Chris-Stratton said in Omega2 - LEDE or OpenWrt?:

    Ok thanks. I'll buy one of those then.

  • @WereCatf said in Omega2 - LEDE or OpenWrt?:

    I tried to tell you, it still wouldn't be identical.

    You are right. "identical" was the wrong word. Still, I insist publishing the .config would be helpful, if only as a point of reference.
    And giving it to us would be an easy step for @onion to go, right now. I can understand though that cleaning up and publishing everything might take more time…

  • @luz said in Omega2 - LEDE or OpenWrt?:

    Still, I insist publishing the .config would be helpful,

    Would be nice, that at least, now where just omega 2 is in hype, that we would get the info's for omega one. Then a community firmware could give continuation to this small devices.

    I don't know what @onion is thinking, some kind of knowledge is power, let's use it a bit more!

  • To anyone interested: I made it yet slightly easier to get going with a custom firmware using my git-tree. All you (should) need to do to set it up, is install git and run the following three commands:

    git clone -b image https://github.com/WereCatf/source.git lede-omega2
    cd lede-omega2
    bash ./first_time_setup.sh

    Or you can download a zip-archive from github, extract it and then run the first_time_setup.sh in there.

  • @WereCatf , is there a .bin file i could test? Before i get in to compiling i would like to see how it "feels". I do have a Omega2+, does this work too?

  • Hi @Luciano-S I would be more confident on @WereCatf image, for sure, but here is mine for the Omega2+ if you wanna try http://www74.zippyshare.com/v/v8arpumN/file.html

    Both fast-gpio and omega2-ctrl working. I installed nano, as I prefer it to vim. I can guide you through wifi setting if you test the image.

  • @Iker , my browsers malaware scanner quotes zippyshare as malaware page .. You dont have a dropbox where you could send me the link per chat.

    I will test your image and give feedback then 😉

  • That's weird. Not dropbox, you can try this: http://s000.tinyupload.com/index.php?file_id=09478120683601055815

    Or I'll see tomorrow how to get a public link from my owncloud.

  • @Iker this time the malaware just was a popup ... now i got it.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.