We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

help omega2 not working

  • @luz Doesn't seem all that sensitive or difficult to power to me. I just slapped one of the el cheapo, cheap-as-chips, eBay switching-mode step-down modules to it and POOF -- off she goes. Seems totally stable and all.

  • I am having the same problem, but I'm using an arduino as power source. I've already tested with a raspberry too but I'm having the same problem. I believe that the lack of current is causing this. I will try to build a step-down and post here the result.

  • I'm having the same stack trace with a 2 Amp 5v adapter connected to the expansion dock (also tried a usb wire directly to my pc), but I don't seem to have any problems with accessing the web ui or turning itself off. I have yet to connect any usb peripherals.

    [   11.254083] ------------[ cut here ]------------                                                                             
    [   11.258782] WARNING: CPU: 0 PID: 476 at drivers/spi/spidev.c:719
    init_module+0x533c/0x5dec [spidev]()                        
    [   11.649524] ---[ end trace 2720e5d9d588bb52 ]---

  • @joe-lones The spidev-warning just comes from the fact that it's defined in the device-tree table. It's nothing more than some kernel-developer didn't like doing it like that for aesthetic reasons and decided to put the warning there, it doesn't actually affect functionality in any way or form. It literally has zero effect, it's just the same as if you loaded the module after booting the kernel, and the only reason the warning is there is aesthetics. You can ignore it.

  • @luz Yeah, true. I'll try some other regulators, and definitelly, I'll keep an eye on the berrydock (need to figure out, where to get a single board - I'm not the best in making double sided pcb's :)) ! Thanks for tip! 🙂

  • AFAIK the stack trace is just a stupidity in the spi driver - whining not to use generic spi drvier device name. You can either patch the devicetree or the driver, but everything should work. What happens if you press enter on the serial console?

  • @Kit-Bishop
    Everybody suggesting docks but omega2+minidock+shipping expensive than other brand quadcore 512mb ram sbcs, I am getting used to omega which is arrived 2 days ago but first seem its still underdevelopment stage. I figured out power and initial setup issue after 1 day.
    Please use a serial debugger and press f while boot and enter failsafe mode

    command firstboot will bring omega2 to factory settings
    after supplying enough current 3.3v input omega will reset to factory default and you can continue to initial setup prosses.

    At least above worked for me.

    After attemping unsuccesfull wifi connection on initial set up, wifi dissepeared on my omega2 and a checked that /etc/config/wireless file corruped.
    i followed above steps and worked for me.

    please be patien after this
    [ 18.201232] EEPROM:Read from [factory] offset 0x0,length 0x400.

    this takes 2-3 min to pass

  • hi guys, had same issues, the omega2+ was booting up until EEPROM message, then the led would go off. I dont have the docks, just connected via serial with Putty. Managed to fix it by using another 3.3v supply (ams1117). Initially i was using a breadboard power supply and seems like it wasnt providing enough power

  • Hi! I got my omega2 and on omega2+ just few days ago and I have the same issue on both. omega2+ just do nothing after "EEPROM:Read from [factory] offset 0x0,length 0x400.", but omega2 just reboot after this.

    I upgraded firmware to v0.1.7-b142.bin, reset to factory settings with firstboot, but still got the same problem.

    Do you have any suggestion?

  • @Sergej-Sevrjuk Sounds like you're having power-issues. The message about EEPROM happens around the same time it tries to bring WiFi up and that causes a current-spike, but if your power-supply or cables can't handle the spike there's a brownout and the device restarts.

  • @WereCatf I use 5v2A -> ams1117 + 1.0F capacitor. Is this enough to power omega2?

  • @WereCatf I tried power up omega with 2 x ams1117 and now it's running. Thank you, for help!

  • @Sergej-Sevrjuk

    AMS1117 @ 2 AMPS ? Please check the datasheet.

    One AMS1117 should be more than enough

  • administrators

    @Sergej-Sevrjuk Please see our article on running the Omega with no Dock: https://docs.onion.io/omega2-docs/hardware-prep-no-dock.html

    We've confirmed that setup work well with the Omega2. For best performance and the most functionality, we recommend using the Omega with a Dock!

  • As it was still unclear from this topic, I think, I'll add my comments to the process.

    I didn't purchase any boards, so I've stuck on this topic pretty heavily.
    I have a lab power supply in my possession, so I didn't thought it would be the matter. It had like 5 amps of power at constant 3.3 volts.
    Still I had to solder up a 104 right to the legs of the MC and add another 470uF to a breadboard in parallel, and I raised voltage up to 3.4, then and only then it did work.

  • hey @luz you said I've done an application-specific mainboard (with a WS2812 LED output and RS485 interface) i'm wondering if you made some kind of modification in the serial driver to handle flow control with RS485,

  • @Miguel-Miranda no, I just used a free GPIO to enable rs485 drivers from my highlevel software. That's far from optimal of course, because I have to estimate how much time my outgoing data will need and time the GPIO accordingly. But for my application (Swiss railway split-flap displays) this was good enough.

    Of course, that's something that probably could be done better at the driver level. I haven't dug very deep, however I'm not sure the UART hardware could provide the needed all-data-is-sent-IRQ. The way MediaTek integrated the UARTs is a bit sad, because they did not provide a way to multiplex the native UART handshake signals to pins.

    It would be nice if proper HW handshaking could be done entirely in software, though. I'm open to proposals how that could work 😉

  • @fossette what current rating is advisable ?
    I read it is 500mA. But is it fine if it is 700mA?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.