We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ fails to connect to wifi

  • @crispyoz Thanks for the tip to turn off Automatically Optimize Network. I will try that.

    However, it took me 10 minute to find the setting. For future reference: it is in the top "Site" tab, not any of the 30 other pages in the 'Settings'.

  • @crispyoz Thank you for this tech insight.

    I do wonder with @Stephen-Tunney why no-one from Onion is remotely looking and solving this issue, after TWO years!
    Luckily I have an ethernet dock, otherwise I would go bonkers.

  • @Axel-Roest I think Onion should just document the country option setting so users can understand what it is used for, since the warp core driver is not opensource, otherwise we could just look at the source.

    I still don't see it as a defect, since switching the country option off fixes the issue.

  • @Ganescu-Theodor

    OMG, this worked! I have been working on this for days. Tried your 'remove option US' all the time, but the devil is in the details.
    I connected using the ethernet dock, as the AP wifi would disconnect every 30 seconds.

    My steps

    1. firstboot -y
    2. sync
    3. reboot
    4. Connect to the AP wifi (Omega-####). This seems to setup some networking.
    5. Connect to the Omega over ethernet (but first purge ssh_key in .ssh/known_hosts)
    6. Removed the line 'option country 'US' from /etc/config/wireless
    7. reboot, again
    8. Added wifi network with wifisetup add -ssid MyNetwork -encr WPA2 -password MyPassword
      (wifisetup list shows a disabled network)
    9. Added another wifi network wifisetup add -ssid MySecond -encr WPA2 -password MyPassword
      (I do not know if this is necessary, but we are in voodoo mode now, so just listing all the steps)
      (now wifisetup list shows the first network enabled)
    10. ifconfig shows the Omega connected to apcli0, eth0 and br-wlan!

    Even better: my UniFi AP-AC-LR router shows the Omega in its client list.


    This was all on BusyBox v1.28.3 () built-in shell (ash), with Ω-ware: 0.3.2 b230

    Disconnected the ethernet cable and reset the Omega, and it keeps connecting to the wifi. Incredible.

    Now I just want to know how I can safely remove the default Access Point (ap) network, as that is a big security issue? Nothing about that in the Onion documentation of course...

  • @crispyoz
    In that I respectfully disagree, as it is a default value for only 5% of the world's population. Furthermore, it is only documented for people well versed in OpenWRT setups, which is not the target audience of this 'user friendly' device, and the feature is completely undocumented on Onion's website. So I would call that a defect.

    If they spent 10% of the money on the beautiful packaging on proper testing, we might not have had this issue.

    Just my $0.02 opinion.

    Also just installed haveged, thanks, but I don't know if the better random generator will help here.

  • @Axel-Roest I'm not sure the issue effects 95% of the world, I have my devices spread across Australia, New Zealand and a few in Indonesia, none of which have the issue. My suspicion is that the issue is some compatibility between wifi hardware sold in different markets, just as I shouldn't by a mobile phone designed for the US market as I will have some issues here in Australia since there are differences in the radio used. Some simple documentation would resolve the issue, just as we set the timezone, we should set the country. We just need the information made available.

    Ubiquiti Unifi hardware also runs OpenWRT and I probably have a dozen sites using Ubiquiti hardware so this suggests to me it is not an underlying compatibility problem.

    Regarding removing the default access point, you can't, if you disable it you disable client as well, there have been many threads on this issue. My solution is twofold, 1) hide the SSID; 2) set a complex password.

  • @crispyoz Oh wow. I have not even seriously looked into that issue, first-things-first, so to speak.
    I did notice nothing worked when I simply tried to remove the 'ap', or set the mode option to 'sta' instead of 'apsta'.

    Thanks for the enlightenment. There are already 40 access points visible on my laptop, so I will just need to think of a funny name.

    A Raspberry-Pi Zero is also starting to look more and more enticing for this project, but alas, I bought three of these Onion Omega2s and they should be put to good use.

  • @Axel-Roest in your /etc/config/wireless section config.wifi-iface 'ap' add th option:

    option 'hidden' '1'

    This will hide the ap ssid.

  • @Axel-Roest said in Omega2+ fails to connect to wifi:

    Now I just want to know how I can safely remove the default Access Point (ap) network, as that is a big security issue? Nothing about that in the Onion documentation of course...

    Please let us know what is that Omega2 AP "big security issue"?

  • @György-Farkas

    Any visible wifi network is bound to get attacks and WPA/2 crack attacks, which is an attack vector into your home or office network. Especially since OpenWRT is set up by default as an access point, which forwards traffic to the wwan network, i.e. your main network.
    I've set up firewall rules for the VLAN my iot devices are on, but still, less than optimal.

    Would you rather have an extra door or a solid wall in your bank vault?


  • @György-Farkas where the hell is the Onion team on this crap?

    Fix your wifi for the planet, or kindly give me my money back for ALL of the stuff I have purchased! I'm not going through and rebooting these things half a dozen times to get wifi AND USB disk space added to my device. The steps aren't even guaranteed to work.

  • This post is deleted!

  • Just to note that this has been yet another FULL three(3) years with no resolution on the current platform provided by the company. No matter what tips or tricks I tried, this piece of garbage STILL doesn't work here in Canada.
    Onion please give me a way to return this $h!T and get my money back, ALL of it.

    Just write up a doc, tested and verified if you have to that PROVES that this stuff works with a few extra steps. Don't make people read endless efforts and failures for HOURS of wasted time in trying to debug something that WORKED with the original firmware!

    Also, provide the ORIGINAL firmware on your download URL (http://repo.onioniot.com/omega2/images/) so that some of us can at least limp along with old crap rather thank a useless brick!
    @crispyoz @György-Farkas I don't know if you work for Onion but you seem VERY active here in the forums. Can you please connect this to the right folks and get this escalated?

  • Having this issue with a brand new Omega 2 Pro. Connecting to my WiFi network results in an infinite loop of the below message. I have tried messing around with compatibility settings in my Unify controller, but nothing resolves it. Also tried the suggestions made here. Unfortunately without success either. I can get it to connect to my iPhone as hotspot. Upgraded the firmware this way, but this didn't help either.

    Weirdly enough I have an Omega 1 and an Omega 2 (not plus) connecting without issues to this network...

    Interface apcli0 link up! (WPA2PSK AES)

  • @Paul-Koene For me the problem turns out to be in the length of the WiFi key. I had a key using the maximum allowed length. After reducing it to 31 chars it works fine.

  • In my case the problem was caused by long list of configured networks.

    wifimanager list

    I removed old wifi configurations using

    wifimanager remove -ssid <ssid>

    left only 2 up there and it works!

  • @crispyoz said in Omega2+ fails to connect to wifi:

    Вам понадобится работающий сервер rsyslog

    How to setting up resend logs to rsyslog?

  • @Alexandr-Didenko Please, could you start a new topic for this question? In forums it is good practice to do so when you ask a new question, it makes it easier for other people to later find this same question. Also, this thread was dead for 2 years and is now on top of the active list again (another bad habit).

Looks like your connection to Community was lost, please wait while we try to reconnect.