We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Ethernet expansion - RJ45 connector

  • Just wondering if I could just attach a RJ45 connector directly on the pin out of omega 2 's Ethernet Rx/TX pin outs without buying an Ethernet expansion?

    Thanks a lot!

  • @Ls-Song No, you can't.

  • You would be missing the magnet... More details here:

    @Matthias-Nowak said in Suggestions and Ideas for custom Omega2 Docks:

    if you take a look at the official ethernet expansion you only see two parts: the jack itself and the magnet for ethernet.

  • Thanks for all your reply... Looks I have to purchase the Ethernet expension...

  • @Ls-Song , could you please correct the typo in the title? ... maybe you could add "Ethernet expansion - RJ45 connector".

    So we get a clue in the title about what your request is.

  • @Luciano-S. Thanks for the suggestion! I just did the modification as suggested. I am too busy fitting Omega 2+ into my home automation... 🙂

  • Despite procuring the parts I'm yet try it (opted instead to run that test on a Linkit Smart in its own dock), but I think that if you have something like the Sparkfun breakout for an RJ45 with integrated magnetics and you add some bias resistors as appropriate, then you probably could make your own working wired Ethernet interface.

  • I cannot enable the eth0 interface on my Omega2 !

    I tried as suggested in the document and I get a "Permission denied" response ...

    Ω-ware: 0.1.9 b149

    root@Omega-E53B:~# /etc/config/network
    -ash: /etc/config/network: Permission denied

    What am I doing wrong ? I tried to log in again , but made no difference

    Help, please !

  • I have used the eth0 interface as shown in this image :


    It should work.... if only I can enable the interface !!

    The RJ45 jack can be any one of many types available in the market, with integrated magnetics.

  • @Shashi-Alabur said in Ethernet expansion - RJ45 connector:

    root@Omega-E53B:~# /etc/config/network
    -ash: /etc/config/network: Permission denied

    You're trying to execute it, but it's not an executable file; it's a config-file. You open it with nano or something to edit its contents.

  • Please note the "RJ45-Ethernet-magnetics" module's center-taps (one on TX and one on RX side)
    <-- this is the side facing Ethernet MAC transceiver on the SoC
    should not be connected to Vdd.

    Omega 1's AR9133 SoC is supplying 2.0V (as Net_Power or Vout pin) while
    not needed on Omega 2's MT7688 SoC.
    This is why Omega 2's Vout pin is left floating, not 2.0v, nor 3.3v is seen on that pin.


  • @WereCatf How do I edit any of these files ? Opkg says "nano" is not available to install. In the list of files that I get when I type "opkg list" does not show any editors which I may install !

    Also, I am able to remain connected through a ssh session using PuTTY on, but when I open the same on my browser, I do not see anything on the screen .. no Console or Terminal or gpio tool or settings ... nothing ? This was showing up just a couple of days ago and I could even make an led on a gpio go on or off. Through the ssh session, I can verify that the console, terminal applications are all installed and up to date.

    Any idea why ?

  • @Shashi-Alabur Since you can connect via SSH, if you are working in Windows then take a look at WinSCP, Onion has good instructions here. WinSCP enables you to use your familiar Windows editor with the Omega's files.

    Re the Onion Console not connecting - try using another browser - Chrome or Firefox or try clearing the cache in your browser. If these fail, maybe time to factory-reset or update firmware.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.