We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Not booting, but drawing 160mA

  • @Martin-Alge Well, you probably should contact Onion via e-mail and ask for a replacement.

  • @WereCatf

    if they don't want the broken one back, i'll try to hit it with a heat gun to see if i can reflow the solder, maybe that will do something

    Thanks for the help!

  • Hi, it seems I have the same problem. Does not start and consumes 160mh. How have you connected the serial cable? I have only a shield with USB but connecting shows no USB serial com port.

    If you get only update from onion please give me an update.

  • @Volker-Helms Here's further tips to use the first Serial Port to help debug.

  • I did have an MT7688 module from an entirely different vendor stop in a similar way at the point where U-Boot switches to trying to execute from DDR, and after reporting an implausible memory size.

    That module was already soldered down to one-off board prototype worth far more than the module, so I went for broke by removing the shield can and reheating the SoC and DDR2, with the result that it booted up, but I do this kind of thing routinely. The SoC is a challenging package - like a QFN, but every other pad is underneath on an interior row. And the DDR2 is likely a BGA - these kinds of things can be fixed with care, but it's not a first resort unless the chance of making it work today beats the risk of destroying it entirely.

    It would be worth trying another power supply or a large capacitor across this one, and triggering the hardware reset line subsequent to power just be sure it's not starting up badly.

    If you do try working on it and get the shield can off, see if it will start up with firm finger pressure on one chip or the other. May also worth looking at the clock crystal.

  • Hi again, after some additional investigation i have no idea why my Onion is not booting. I have no extension to check the serial output and so my only info is "wifi not starting" and "draws 160ma after power on". I have created some pictures. Maybe someone can help me to check if there are any bugs on the board.

    Thanks!5_1486672334015_IMG_0035.JPG 4_1486672334015_IMG_0038.JPG 3_1486672334014_IMG_0036.JPG 2_1486672334014_IMG_0039.JPG 1_1486672334014_IMG_0037.JPG 0_1486672334014_IMG_0040.JPG

  • @Volker-Helms I tried to look through your pictures, but I ain't spotting any obvious solder-bridges. Maybe invest in a USB serial-adapter and see if it says anything? Something like e.g. http://www.ebay.com/itm/CP2102-USB-2-0-to-TTL-UART-Module-6Pin-Serial-Converter-STC-Replace-FT232-Module-/381374541932 is cheap as chips and works well. You may be able to find ones closer to you, too, that's just the first one I picked on the list of results. (Do note, I don't recommend CH340-based ones. I have a couple CH340-based ones, but none of them work well with the Omega2, whereas the CP2102- and CP2104-based ones work just peachy)

  • It's not clear from the photo, but can you make sure you don't have a short around the shiny areas in this zoomed section of one of your photos?

    0_1486678248104_upload-0e2be0b6-3125-4f8e-b0c3-d384e43ecd09 ![alt text](image url)

  • The mis-identification of 1MB DRAM is mosty likely due to a soldering or component problem entirely contained within the shield can - you are unlikely to understand or resolve it from the outside as the signals involved are unlikely to venture outside the shield can (having them do so would rather defeat its purpose).

    On the MT7688 board from another vendor I had which exhibited this problem, all I could seen under my soldering microscope was that the portion of the SoC's outer ring of pads projecting beyond the edge of the package did not look as nicely "wetted" as I would expect to see.

    Even then, visual inspection only gave me a clue as to the problem, nothing definitive.

    The only way I actually know that my board from that other vendor had a soldering problem, is that fluxing the SoC and DDR and reheating them left me with a board that worked when it cooled.

    So for the board in the original post reporting 1MB DRAM, the options are either to take it apart yourself and resolder it, or send it back.

    For the board subsequently appended to this thread by a different poster and without any conclusions from the serial console there is no basis for thinking the problem is related to the history of this thread at all. The best approach there is to acquire a USB serial solution (it will be needed sooner or later anyway) and determine what if anything it outputs on boot.

  • Thanks for your support. And @Chris Stratton you are right, capturing a thread is not so good. First I thought it could be the same problem. But you are right, without a serial console I cannot compare it. So i will buy a serial adapter and check what happens then. I will also check if I have a shorting.

    Sorry for that.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.