We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

1-Wire Temperature Sensor - DS18B20 - on Omega2

  • @WereCatf Looked at there ask, and they seemed to want a higher resolution (say in drivers/pinctrl) to prevent the need for the assumption/check where you did it.

    With that, if you had to fix this bug higher up ( or down, depending on how you look at it) the stack, what would be a broader resolution? And would you still need that check in the specific driver file you made?

    I do dislike the general "suggestions" or "I wouldn't have done it that way" as a means to squash a PR, but I do like issues resolved at where they occur earliest. I'm asking as I want to learn from your way of thinking about this šŸ™‚

  • @Theodore-Borromeo This issue has been around for fricking years and no one has fixed it "properly" and no one, who actually has the skills to do it, is willing to! But then no one is also willing to accept this patch, even temporarily, which comes to my opinion: it's idiocy. Getting things working should be more important than aesthetics, especially if the issue lingers around for years and years and nothing is ever done about it!

    Yes, fixing things up in pinctrl would possibly be the "most correct" way of fixing things, but it's not happening. On the other hand, this is just a simple two-line patch, so it would be extremely easy to apply for now and remove one day in the future, if someone decided to fix things "correctly."

  • @WereCatf I agree completely. Especially as, if it is fixed 'upstream', and your patch stayed, there is minimal effect should it stay in place! On top of that, as you are pointing out, "everyone wants the perfect patch, but ain't no one wanna write the perfect patch!" šŸ˜‰

  • Hi All, so what do I have to do to install your patch? I need a temperature controller for my next project.
    Keep up the good work! šŸ™‚

  • @WereCatf

    Just think of all the other sensors that have to be "worked on" by the Onion programmers !

  • @Morten-Egge You can't apply the patch to the official firmware, you need to compile your own or wait for the Onion devs to fix theirs. I have already included the patch in my LEDE-sources.

  • @WereCatf Thanks for the update/answer, hopefully the onion team will adress this issue. I have a project that requires the one wire sensor. I do understand that the onion team has a lot on they're plate right now.

  • I get also this gpio error šŸ˜ž . When Onion correct this to firmware?? I have firmware 0.1.9 (b149) and it don't work!!! Please do something!!

  • @Lazar-Demin any idea when 1-wire will be returned to the firmware so we can all hook up our sensors?

  • This is basically the "hello world" of sensors programs and it is broken. šŸ˜ž I'm beginning to wonder if the MKR1000 would have been a better option.

  • Onion issued a post on GitHub that they are planning to look at 1-wire this week.

  • firmware update arrived:


    February 2, 2017

    • Added patch to fix 1-wire master issue where virtual nodes were not accepted as gpios
    • Infra: added option for quick (essential) compile
    • Infra: reorganized patches

    I guess they patched it, will check later...

    As far as I can tell it is working šŸ˜‰ did my first reading.

    Following the Omega (1) instructions:


  • How do we do an upgrade to b151 without losing everything we have installed to /usr/bin?

  • Confirmed as working fine on my 2+


  • @Costas-Costas Did you find a solution for your backup problem?

  • Nope, reinstalling now.

  • At a crude level you could probably do something like tar up everything in /overlay to /tmp, and scp that off. The question would be if you could then put it back exactly, or if you would have to do so piece by piece. If changes to the underlying system are small it might go back exactly.

    But LEDE/openwrt normally have their own backup capability when doing a sysupgrade.

  • It is still not working for me. I just upgraded to the b151 firmware. I got the directory /sys/devices/w1_bus_master1, but I got slave entries like:

    root@omega:/sys/devices/w1_bus_master1# ls -1d ??-*

    And it keeps changing. But I never see the correct serial number of the device.

  • @Bertalan-Gergaly that suggests you haven't wired up the sensor correctly.

  • My first thought was exactly that. So I redid the wires before posting. Same result.

    I did a check just now. The data pin is not connected to the omega, just the ground and the power and I still got the weird devices:

    root@omega:/sys/devices/w1_bus_master1# ls -1d ??-*

    And I just did a retest without anything connected to the omega and I still got the weird devices:

    root@omega:/sys/devices/w1_bus_master1# ls -1d ??-*

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.