We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Reset Button not working on Minidock

  • @WereCatf
    i think its the problem of this particular omega2+

    Case 1. When i connect the VIN pin and FW RST pin, it kept restarting and the LED blinks slowly (roughly 1-2s)

    Case 2. I got another power dock, when i plug this bricked omega2+ to the power dock and turn on while pressing reset button, the LED keeps blinking slowly (roughly 1-2s, the interval is similar to when connecting VIN pin and FW RST pin)

    it seems like in both case, the omega2+ is in a restarting loop.
    the power dock does not have any serial chip, so i'm sure that there shouldn't be any input provide to the omega2+

    any idea how can i unbrick my omega2+ ?
    i only owns a minidock and a power dock.

    (actually i don't understand how i bricked it in the first place, i was just running the initial setup and i did waited until the update complete. it was bricked after the reboot after completing the update)

  • My reset button on my mini dock does not work either. I submitted a ticket with Onion's help desk over a week ago with photos and a video and haven't heard anything back yet. One of the reasons I had ordered the mini dock was to be able to easily unbrick a unit and with the reset button not functioning that functionality is gone.

  • It seems like you should be able to determine if there is a hardware fault in the dock reset circuit by measuring the appropriate pin with a voltmeter, powering the dock with no omega installed, or potentially exploring the dock board with an ohm-meter when it is unpowered and has no omega installed.

    Similarly, one the boards with USB-serial, you could test them by removing the omega and installing a small piece of fine wire between the two serial holes of the omega socket; with the wire a serial terminal program should see echo of typed characters, without it, it should not (unless it locally generating an echo, in which case with the wire you will see two of every character typed, and without only one).

    The point would be to differentiate between possibilities:

    • Something wrong with the computer serial setup
    • Something wrong with the dock (bad button or connections)
    • Something wrong electrically with the omega2 (missing or shorted connection, etc)
    • Something wrong with the omega2 flash state, like a corrupted U-Boot, kernel, or filesystem

    Of course insufficient power supply is another thing to suspect.

  • I also have an arduino 2 dock. Both of my Omega2+ units respond to the reset button on that one, neither do on the mini dock. I can bring up the terminal on both units via serial connection when connected to my computer via the mini usb port on the mini dock. I have a 2.4a Anker charger that I've plugged the mini dock into and the reset button doesn't work with either omega2+ unit I have. The reset button on the mini dock simply doesn't work.

  • alright, i just plugged in the working omega2+ to the minidock to check.
    it seems like the minidock is somehow generating some weird repeating "@^" characters
    when i logged in via ssh concurrently, the omega2+ seems to be working fine

    weird part is i don't get any of those repeating "@^" characters when i use the bricked omega2+

    i also tried putting a wire connecting serial RX0 to TX0
    nothing shows in the console when i try to type
    then i tried RX1 to TX1, same result
    (although i believe for the minidock, the chip is connected to RX0 & TX0)

    below is what i get when power on the device (connected a working omega2+ on minidock, serial, using 115200)

       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    Board: Onion Omega2 APSoC DRAM:  128 MB
    relocate_code Pointer at: 87f60000
    flash manufacture id: c2, device id 20 19
    find flash: MX25L25635E
    *** Warning - bad CRC, using default environment
    Onion Omega2 UBoot Version:
    ASIC 7628_MP (Port5<->None)
    DRAM component: 1024 Mbits DDR, width 16
    DRAM bus: 16 bit
    Total memory: 128 MBytes
    Flash component: SPI Flash
    Date:Oct 18 2016  Time:17:29:05
    icache: sets:512, ways:4, linesz:32 ,total:65536
    dcache: sets:256, ways:4, linesz:32 ,total:32768
    CPU freq = 575 MHZ
    Estimated memory size = 128 Mbytes
    Resetting MT7628 PHY.
    Initializing MT7688 GPIO system.
    * Hold Reset button for more options *
    Boot Linux from Flash NO RESET PRESSED.
    ## Booting image at bc050000 ...
       Image Name:   MIPS LEDE Linux-4.4.42
       Image Type:   MIPS Linux Kernel Image (lzma compressed)
       Data Size:    1306381 Bytes =  1.2 MB
       Load Address: 80000000
       Entry Point:  80000000
       Verifying Checksum ... OK
       Uncompressing Kernel Image ... OK
    No initrd
    ## Transferring control to Linux (at address 80000000) ...
    ## Giving linux memsize in MB, 128
    Starting kernel ...
    [    0.000000] Linux version 4.4.42 (root@2272a3272872) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3009-968fa53) ) #0 Mon Jan 16 19:40:14 2017
    [    0.000000] Board has DDR2
    [    0.000000] Analog PMU set to hw control
    [    0.000000] Digital PMU set to hw control
    [    0.000000] SoC Type: MediaTek MT7688 ver:1 eco:2
    [    0.000000] bootconsole [early0] enabled
    [    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
    [    0.000000] MIPS: machine is Onion Omega2+
    [    0.000000] Determined physical RAM map:
    [    0.000000]  memory: 08000000 @ 00000000 (usable)
    [    0.000000] Initrd not found or empty - disabling initrd
    [    0.000000] Zone ranges:
    [    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Movable zone start for each node
    [    0.000000] Early memory node ranges
    [    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
    [    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
    [    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
    [    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
    [    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
    [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
    [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
    [    0.000000] Writing ErrCtl register=000575ef
    [    0.000000] Readback ErrCtl register=000575ef
    [    0.000000] Memory: 125552K/131072K available (3012K kernel code, 143K rwdata, 724K rodata, 208K init, 196K bss, 5520K reserved, 0K cma-reserved)
    [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
    [    0.000000] NR_IRQS:256
    [    0.000000] intc: using register map from devicetree
    [    0.000000] CPU Clock: 580MHz
    [    0.000000] clocksource_probe: no matching clocksources found
    [    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
    [    0.000012] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
    [    0.007522] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
    [    0.070038] pid_max: default: 32768 minimum: 301
    [    0.074639] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.080978] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.094334] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
    [    0.103980] pinctrl core: initialized pinctrl subsystem
    [    0.109719] NET: Registered protocol family 16
    [    0.133428] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.138966] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.144400] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.150915] i2c-mt7621 10000900.i2c: clock 100KHz, re-start not support
    [    0.158443] clocksource: Switched to clocksource MIPS
    [    0.164815] NET: Registered protocol family 2
    [    0.169921] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.176613] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.182796] TCP: Hash tables configured (established 1024 bind 1024)
    [    0.189000] UDP hash table entries: 256 (order: 0, 4096 bytes)
    [    0.194603] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    [    0.200945] NET: Registered protocol family 1
    [    0.210689] futex hash table entries: 256 (order: -1, 3072 bytes)
    [    0.216639] Crashlog allocated RAM at address 0x3f00000
    [    0.237024] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    [    0.242677] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
    [    0.254844] io scheduler noop registered
    [    0.258644] io scheduler deadline registered (default)
    [    0.264408] rt2880-pinmux pinctrl: pin io18 already requested by pinctrl; cannot claim for 10005000.pwm
    [    0.273489] rt2880-pinmux pinctrl: pin-18 (10005000.pwm) status -22
    [    0.279501] rt2880-pinmux pinctrl: could not request pin 18 (io18) from group pwm0  on device rt2880-pinmux
    [    0.288903] mtk-pwm 10005000.pwm: Error applying setting, reverse things back
    [    0.296246] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
    [    0.303810] console [ttyS0] disabled
    [    0.307243] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
    [    0.316025] console [ttyS0] enabled
    [    0.316025] console [ttyS0] enabled
    [    0.323019] bootconsole [early0] disabled
    [    0.323019] bootconsole [early0] disabled
    [    0.331702] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
    [    0.341198] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2500000) is a 16550A
    [    0.351776] spi-mt7621 10000b00.spi: sys_freq: 193333333
    [    0.361855] m25p80 spi32766.0: using chunked io (size=31)
    [    0.367351] m25p80 spi32766.0: mx25l25635e (32768 Kbytes)
    [    0.372919] 4 ofpart partitions found on MTD device spi32766.0
    [    0.378847] Creating 4 MTD partitions on "spi32766.0":
    [    0.384065] 0x000000000000-0x000000030000 : "u-boot"
    [    0.390884] 0x000000030000-0x000000040000 : "u-boot-env"
    [    0.398114] 0x000000040000-0x000000050000 : "factory"
    [    0.405158] 0x000000050000-0x000002000000 : "firmware"
    [    0.452889] 2 uimage-fw partitions found on MTD device firmware
    [    0.458938] 0x000000050000-0x00000018ef4d : "kernel"
    [    0.465621] 0x00000018ef4d-0x000002000000 : "rootfs"
    [    0.472575] mtd: device 5 (rootfs) set to be root filesystem
    [    0.478387] 1 squashfs-split partitions found on MTD device rootfs
    [    0.484728] 0x0000006e0000-0x000002000000 : "rootfs_data"
    [    0.501956] rt3050-esw 10110000.esw: link changed 0x00
    [    0.509704] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
    [    0.518303] i2c /dev entries driver
    [    0.522502] mt7621_wdt 10000120.watchdog: Initialized
    [    0.529238] NET: Registered protocol family 10
    [    0.537734] NET: Registered protocol family 17
    [    0.542412] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
    [    0.555228] 8021q: 802.1Q VLAN Support v1.8
    ^@^@^@^@^@▒^@^@^@[    0.567037] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
    [    0.575408] Freeing unused kernel memory: 208K (803cc000 - 80400000)
    ^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@▒^@^@^@^H^H^@^@^@^H^@^@^@^@^@^@^@^@^@^@^A^@^A ^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^B^@^@^@^@^@^B^@^@^@^@^@^H^@^@^@^@^@^@^@▒^@^@^@^@^@^H^@^H(^@^H^@^@^@^@^H^@ ^@^@^H^@^@^@ ^P^@^@^H^@^@^@ ^@(^H^@^H^@^@^@^@^@^@ ^A^B^@@^B^@^@ ^@^@^@^@^H^@ ^H^@ ^H^@(^@^@ ^@^H^@^@@^@^H^@^@ ^@^H^@^@^@^H^@^H^@^@^@ ^@^H^@^@^H^@^H^@^H^@^@^@^@^@ ^@ ^@^@@^@^H^@^H^@ ^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@@^@^P^@^@ ^@^@^@^@^@@^@^@^@^@^@^@^@^A@^@^@^@^@^@^A^@^@^@^@^@^@^@ ^@^@^A▒@^@^A^P^@▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^H^@^@^@^@^@ ^@%^@^H^A^@^B^@^@^@▒^@ ^@^@^@^@▒^@^@^@^@ ^@^@^@^@^^@^@ ^@^@^@^@ ^@^@^@^@^@^@^@^H^@^@^@^@^@^@ ^H^H^@^@^@^@^@^@^@ ^@^@^@^A^@^H^@^B^@^@^@^@^@^@^@^@^@^@^@^@^C^A @^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@[    1.614352] init: Console is alive
    [    1.618131] init: - watchdog -
    ^@^@▒^@^@^H▒^P^@^@^P^@^@^@^@^@^@^@B^@^@^@^@^@^@^@^@^@^@^@^@B^H^B^@@^@^@^H^@^P^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@( ^@^@(^@^@^@ ^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^H^B^@^H▒@^@^@^@^H^H^@^@  ^@^@^@^@^@^@^@@^@^@^H^H^@^@^@^H^@^@^@^@^@^@^@^@^@^H@^@^@ ^@ ^@@^H^@^A^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^A^@^@^A^H^@^@^@^@^@^@^@^A^@^A^@^A^A^@^@^A@^@^@^@^@@^H^@^@(▒@^@^@(^B^@^@^H^@^@^@^@^@^@^@^@^@^@^@ ^@ @^P^H^@^@^@^H^@^@^@^@^@^H^@^@^@^P^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@    ^@^@^@^@^@@^@^@^@^@^@^A^@^A^@^@^@^A^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^A@^@^@^@^P@^@^A^@^H@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@  ^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@@^@^A^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@▒^@^A^@^@^@^@^@^A^@^@^@^A^@^@^A^@^@^@^H^@^@^@^@^@^@^@^@^@^@^P^@^@^@^@^@^@^@ @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@▒^B▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^A^@^@^@ ^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@@^B^@^@^@^@^@^@^@^@^@^@^@▒^@^@^@^@^@^@^@▒^@^@^@^@^@^@^@^P^A^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@ ^H^@▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^A^@^@^A^@^B^@^@^A@^P^@^A@^A^B^A▒^@^@^@^@^@^@^@▒^@^@^@^@^@^@^@^@^@^@^@^@^@^H^B^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^H^@^@^A^@^A^H^@^A^@^A^@^@^@^@^@^@^@▒^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@A^@^@^@^@^@ ^@^@^@^@^@^@^@^@^A^@^A^@^@^@^@@^@^A^@@^@^A^@^@^@^@^@^@^A^@^@^@^@^@@^@^@^@^A^@^@A^H^A^@^@^H^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^C@^@^@^B^@^@ ^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^^C^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^H ^@^H^@^H^@^@^@^@^@^H@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@▒▒^@^@^@^@^@^@^@^@^H^@^@^@^H^H^@^@^@^A^H^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^A^@^@^@^@^@^@^@^A^@^@^A@^@^@^@^@^A^@^@^@ ^@^@^@^@^@^@^@^@^@^@^H^@^H^P^@@^@^H^@^@^H^@^H^@^@(^@^@^@^@^@^@^@^A^@^@▒ ^@^@^H▒^@^@^@^@^H^@^@^@^@^H^H^@^@@^@^@^@^@^H^B^@^@^@^@^@^@^P^@^@^H^@^@^@^H^@  ^@^@^@^@^H^@^@^@^P^B^@^H^A^@^@^@^@^H^@^@^@^@^@^@^@^H^@^@^H▒^@^@^@^@^H^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^C^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@@▒^@^H^@^@^@^@^H^@ ^@^@^@^@^@^@^@^@^@@^@^@^P^@^@^@^@^@^@^@^L^@^@^@^@^@^@^@^@^A^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@@▒^@^A^@^A^@@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^H^@@^B^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@!^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^H^H^@^@^H^H ^@^@@^@^@^A^@^@^@^@^H^H^@^H
    ^@^H^B^@^@^H ^@^@^@^H^@^@^@^H^@^@^@^@^H^H^@^@^H^@^@^@@^@^@ ^@^@^H^H^@^P^@^@^A^@^@^A^@ ^@^@^@^P^A^@^@^H^@@^@^@^@^@ ^@^@^H^@^H^@^@(^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^A^@^@^A^L^A^@^@^@^@^@^@^@^@^@^A^@^A@^@^@^@^@@^@^@@^@^@^A^@^P^@^A@^@^@▒^A^A^@^@^H^@^@^@^@(^@^@(^@^A▒^@^H^@^@^@
    ^@^@^@^@^@^@^@^@^@^@^@^@^BB^@^@^@^@^@^H▒^@^H ^@^H^H^@^@^@^@^@^P^@^@(^A^P^@^@^@^@^@^@^@^@^@^H^@^@^H^@^@ ^@^@^@^@^@^@^@^@@^@^@^@^@^H^H^@^@^@^H^H^@^@^@^@^@^@^@^@^A^@^@^H ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^P^@^H^@^H^@^@^@^@^@^@^@^A^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^P^@^@^@^@^H^@^A^H^@^@^@^A^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@▒^P^B^@^@^A^@^H^@^@^H^H▒^@^@ ^@^@(^@^H^H^@^@^@^@^@^@^@^@^@^@^@^A^@   ^@^@^A^@^@^@^A^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^B^@^A^@^A^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^A^@^@^@^@^@^@ ^@^@^@^@^@^@@^@^@^H^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^A^@^@^@^@P^@^@^@^@^@^@^A^@^@^A^@▒^@^@A^@^@^@^@^@^A^@^A^@▒^@^@A^@^A^@^A^A^@^@^@^@^@^A@^A^@^H^A^@^A ^@^A^P^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^H^@^@^@^^C^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^A^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@!^@^@^@^@^@^@^@▒▒@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^H^A^@^@^P^@^@^@^H^B▒^P^@^@^@^@^@^@^H^@@^B^@^H^@^@^H^@^@^@^@^@^@^@ ^@^@ ^@^@^@^@^@^@^@^@^@^H^H^@^@^@^A@^@^H^@^@^@^@^@  ^@^@^@^@^@^@^H^@^H^@^H^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^A^H^@^@^A ^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^H^@^@^@^@^@^@^@^B^@^P   ▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^H^@^@!^P^@^B^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^B^H^@^@^@^@^@^@^@@^@^@^@^@^@^@^B^H^@^@^A^@^@^@H^@^@^@^@^@^@^H^@^@^@^@^H^@^A^H^@^@^@^@^@^@^@^@^@^@^@^@$^@@B^@^@^@^B^@^@^@^@@^@^@^@^@^@^@^@^@^@▒^@^A^H^H^@^A^@^@^@^@^@^@^@^@^@^@^@^@@^@ ^@^L^H^@^H^@(^@^H^A@^@^@^@^@^@^@^@^@^@^@H^@^@^@^A^@^B^@^B^H^H^@^@^@^@^H^H^@^H^@^H▒^@^@^H^@D^@^@^@^@^@^@A@^@^A@^@^A^P@^@ ^@^@^@^@^@^@^@^@^@^A^H^@▒^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^H^@@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^H^@^@^@^@^@^@^@^@^@^@^@^@^@@@^@^@^@^@^B^@^@^@^A^@^A^@^A^@^@^@^@^@^@^@^@^@^C^@^@^A^@^@@^@ ^@^@^@^@^@^@^@@^@^A^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^A^@^P^@▒^@^@^@^@^@@^C^@^A ^A@^@^@^@^@^@^@^@^H^@@^@^H^@@^H^@@ ^@ ^B^@A^@@^A^@^@▒^@^@^A^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@  ^A^@^@^@^@^@^B ^@^@^@^@^@@^@^@^A^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^H^@^@^@^@^@^@^@^@^B^H^@^@^@^@^@^B^H^@@^@^@^@^@^@^@^@^@^@^@^@^@^@▒^@^@^@^@^H
    ^@^@^@^@^@^@^@^@^@^@^B^H^@^@^@^@^@@^B^@^@^@^@^@^@^@^@^@^@^@@^@^@^H^@^@^@^@^@^A^@^@^@^@^@^@^H^B^@^@^@^@@^@^@▒^@^@ ^@^@^@^@^@^@^@^A^@^H^@^H^@^H^@^@ ^@^@^@^@^@^@^@@^@^@@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^H^A^@^@^@^@^@^@@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@[    3.964307] random: nonblocking pool is initialized
    ^C^A^@^@^@^@▒@^A^C^A^@^@^@A^H^B^@^@^@^@^B^@^@^@^@^H^@^A@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@@^H^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^B@^@^@ ^@^B^@^@^@^@^@▒^@^@^@^@^@^@^@@^@^B^@^@^@^@^@[    4.191517] usbcore: registered new interface driver usbfs
    [    4.197174] usbcore: registered new interface driver hub
    [    4.202765] usbcore: registered new device driver usb
    ^@^@^@^@^@^@^@^@^@^@^@^@^B@@^@[    4.214590] exFAT: Version 1.2.9
    ^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@ ^H^A^@^@^@^@^@^@^@^@[    4.258812] SCSI subsystem initialized
    ^@^@^@^@^@^@^@@^@@^@^@^@@^@[    4.269684] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    ^@^@[    4.277921] ehci-platform: EHCI generic platform driver
    [    4.293597] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
    [    4.300440] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
    [    4.305771] ehci-platform 101c0000.ehci: EHCI Host Controller
    [    4.311646] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
    [    4.319836] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
    [    4.326144] ttyS0: 1 input overrun(s)
    ^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@[    4.338493] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
    [    4.345967] hub 1-0:1.0: USB hub found
    ^@^@^@^@^@^@^@^@[    4.350368] hub 1-0:1.0: 1 port detected
    ^@^@^@^@[    4.360813] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
    ^B^@^@^@^@^@^@^@^@[    4.368777] ohci-platform: OHCI generic platform driver
    [    4.374348] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
    [    4.381361] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
    [    4.389489] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
    ^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@[    4.453625] hub 2-0:1.0: USB hub found
    [    4.457869] hub 2-0:1.0: 1 port detected
    ^@^@^@^@^@^@^@^@^@^@^@^@^@[    4.475333] MTK MSDC device init.
    ^@^@^@^@^@^@@^@^@^@^@[    4.518624] mtk-sd: MediaTek MT6575 MSDC Driver
    [    4.526583] sdhci: Secure Digital Host Controller Interface driver
    [    4.532932] sdhci: Copyright(c) Pierre Ossman
    [    4.538863] sdhci-pltfm: SDHCI platform and OF driver helper
    [    4.549261] usbcore: registered new interface driver usb-storage
    [    4.565885] init: - preinit -
    ^@^@^@^@^@^@    ^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^H^@  @^@^H^@^@^H^@^@^@^H^@^@ ^@^@^@^H^@^@^@ ^P@^@^@^@ @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^HP^H
    @^B^@^@^@^@^@^H^@^@^@^@P^@^@^@^@^@ ^@^H^@^H^@^H^@^@^@^@^@ ^H^A^@^@^H^@^@^@ ^A^@^P^@^@^@^@^@^@ ^A^@^@^H^@ ^B^@^@^A^@^@^@^@^@^@^@^H^@^@^H^@@^@▒^@^@^@^@^@^@^@^@^@^@^@@^@^A(^@^A ^@^@^@^H^@^H^@^@^@^@^H^@^@^H@^@(^@ ^@^@^@^@^@^@@^H^@^H^@@^@@^H^@^@^@^@^H^H^@^@^@^@^@^@^H^H^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^B^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^H^@P^@^@^H▒^A^@^H^@^@^@^@@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^C^@^A^@^@^A^@^B^@^B^@^@^@^@^A^@^@^@^@▒^@^@^@^@^@^@^@^@^A^@^A^@^A^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@[    5.364356] rt3050-esw 10110000.esw: link changed 0x00
    ^@^@    ^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^B^@^@^@^@^@^@^@^H^@^H^@^@^@^@^@^@^@^@^@^@ ^B^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@      ^@^@^B^@^@^H$^@^@^@^@^@^@^B^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@$^@^@^@^@ ^@^@^@^@^@^@^@^B^@^@Press the [f] key and hit [enter] to enter failsafe mode
    Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
    ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^P^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A ^@^@^@^@^@▒ ^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@(^@^@^@^@^@^@^@^@^@^@^H^H^@^@^@^@^@^H@^@^@^@^A^@^@^@^H^@^@(^@^@^H^@^@^@^@@^@^@^@^@^@^H^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^C^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@`^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^A^H^@^@^@^@^@^@▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^P^@^@^@^@^@^@^A^@^@^A^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^R
    ^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@`^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^A^H^@^@^@^@^@^@▒^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@    ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^P^@^@^@^@^@^@^A^@^@^A^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@H^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^H^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@     ^@^@^@^@^@^@^@^[    8.941307] jffs2: notice: (393) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
    @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^[    8.960593] mount_root: switching to jffs2 overlay
    @^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@[    8.975913] urandom-seed: Seeding with /etc/urandom.seed
    ^@^@^@^@^@^@ ^@^@^@^@^@^@^A ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^C^@^@^A^@^@^A^@^@^@^@^@^@^H^@@^@^@^@@^H^@^H^P^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@[    9.080430] procd: - early -
    [    9.083462] procd: - watchdog -
    ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@[    9.737715] procd: - ubus -
    ^@^B ^@^@^A^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^H^@^@^@^@^@[    9.953928] procd: - init -
    ^@^@^@^@^@^@^@^@▒^@Please press Enter to activate this console.
    ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^H^@^@^@^@^H^H^@@^@^@^@^@^H^@^@^@^@^@^@^@^@^@ ^@^A^@^@^@^@^@^@^@^@^@^@^@^@ @^@^@@@^@^@^@^@^@^@^@^@^@^H^@^H^@^@^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^A^@^@▒^@^@^@^@!^@^@^@^@^@^@^@^B^@@^@@^@^@^A^H^A^A^@^@^@^@^@^@^@^@^H^H^@^@^H^@^@^@^@^@^B^@^H^@^@ ^@^@^@^@^@^@^@^@^@^H^@^@^@^H^@^@^H^H^@^@^H^H^@^H^@^H^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^B^@^H^@^@^@^@^@^@
    ^@^@^@^@^P^@^@^BBusyBox v1.25.1 () built-in shell (ash)
    ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^H^@^@^@^@^@^@^@^@^@^@   ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/

  • @Luciano-S.
    sorry, due to this unnecessary bricked situation, i have no time to worry about mark down
    i followed all the instructions and waited the initial update until it showed successful and yet it's still bricked.
    and i got a brand new minidock that have a non-working reset button and couldn't let me press 2 to fix my bricked omega2+
    it's a big waste of my time, and you are asking me to worry about mark down ?
    why don't you offer a better solution to the problem ?

  • @dennis-ctp said in Reset Button not working on Minidock:

    and i got a brand new minidock that have a non-working reset button and couldn't let me press 2 to fix my bricked omega2+

    I'am sorry about this, just onion.io can change that hardware problem with an RMA.
    In the meantime you just can solve the part they ask for see link on top (if you not did already)
    There are workarounds how you can make your reset button working, but if you are not into electronics and and want to avoid loosing warranty you better wait till you can exchange it or till there is a other kind of solution.

    it's a big waste of my time, and you are asking me to worry about mark down ?

    You right ...it is a big waist of time for all the volunteers here who try to help and have to scroll thorough the kilometer long requests ... it really would cost you just six!!! characters you have to put. 3 high ticks before and 3 after your log you posted (see my linked document!)

  • @Luciano-S. I submitted a ticket for my mini dock problem and it has been 11 days since I provided photos of the dock and video of the nonfunctioning reset button. I asked for a status update after a week with no response and still haven't heard back. The help desk isn't exactly being responsive.

  • @Luciano-S.
    as mentioned above, i already tried the workaround to provide the fw_rst pin with 3.3v
    but the problem is the minidock is defective and the terminal didn't wait for the input and go on a non stop reboot loop.

    and i did read the compose link but i don't know what you want me to mark down.
    so its more time wasted and nothing done

  • @dennis-ctp Mark down everything below "below is what i get when power on the device (connected a working omega2+ on minidock, serial, using 115200)" in your post

    edit: just trying to be helpful here 🙂

  • @cusackph alright & done

  • Arguing about markdown is pointless, the content of useful information is the same either way. If you don't want to read this thread because you find it personally annoying, then don't.

    What would be useful is figuring out if the reset button is actually not being electrically detected, or if the board is going ahead anyway because of inbound serial noise, and where the outbound serial noise is coming from.

  • @Chris-Stratton
    i tried as you suggested, connecting the tx0 rx0 and also tried connecting tx1 rx1
    but both gives me no respond on what ever i pressed.

    and when i try to put a working omega2+ in the minidock and connect via serial,
    i'm getting loads and loads of ^@ character flooding my screen

  • and while waiting for response after opening a ticket in the support,
    i'm trying to play with a sample project using the good omega2+ that i have and found that the gps is faulty because they had an extra capacitor 😢 😞

  • @Chris-Stratton said in Reset Button not working on Minidock:

    Arguing about markdown is pointless, the content of useful information is the same either way. If you don't want to read this thread because you find it personally annoying, then don't.


    What would be useful is ,,,,

    I both agree and disagree with this. I agree that the content of the information is (largely) the same no matter what format it is in, but then so would a hex dump of the information, but no one would want to plough through that! I disagree because on this forum we are all pretty much unpaid and give of time freely to try to assist and the clear presentation of information will be helpful (as distinct from useful) is more likely to elicit a response if the information is clearer to to decipher.
    While it is obviously up to the requester to present the information in any way, the process of communication requires clarity - the clearer the request, the more likely it is to get a response.

    That said, I believe it is more than likely that many people don't know the ins and outs of presenting information via markdown (it certainly took me a while to get used to it and I still don't know it all). Consequently, I have added the following post as a pointer to formatting information using markdown: https://community.onion.io/topic/1583/using-markdown-to-format-posts-for-better-clarity

  • @Chris-Stratton said in Reset Button not working on Minidock:

    Arguing about markdown is pointless, the content of useful information is the same either way. If you don't want to read this thread because you find it personally annoying, then don't.

    Yes .. right .. he just should read the guidelines and publish the high-resolution pictures of his Hardware, which onion.io wants to see if a RMA would be needed. @Chris-Stratton Maybe you will also see what could create the serial noise 😉

    If he already made pictures he should be so kind and post the link. He wants help and it is his interest that it goes on with his problem.

    Keeping a bit order in a public forum has also todo with netiquette. There will be others with same problem after him. They like to find info fast and easy to read/understand.

  • @Chris-Stratton Maybe you will also see what could create the serial noise 😉

    My instincts would be to check bad connections, power supply noise, and mismatched clocks.

    The latter especially from experience - on my other MT7688 system I do not get reliable results at 115200 but only at 57600, which many other MT7688 systems use as a default. It's especially prevalent when I have the MT7688 talking to a microcontroller, but happens sometimes with a USB serial converter (also a CP210x) talking to a PC.

    I've since discovered some clock divider settings in the MT7688 which can variously make the 115200 baud setting more or less accurate, so it's something I've been meaning to find time to look at in more detail.

    Main point is that you can wait for the vendor to do something, or you can make a targeted investigation of the failures. But just complaining about how people post in the threads they start about their own specific problem doesn't really help anyone.

  • 2_1486247127688_IMG_4280.JPG 1_1486247127688_IMG_4279.JPG 0_1486247127687_IMG_4278.JPG
    Image of the omega2+ in question.

  • actually i don't mind formatting a little. its just that i don't know what you want me to format and there's no obvious example in the compose ? link
    instead of starting a new thread, you should just have someone put them in the compose ? link

    if u just tell me straight forward what to do, instead of telling me to worry about markdown, i would have done it instead of feeling more frustrated having to read up something that doesn't helps the dire situation

Looks like your connection to Community was lost, please wait while we try to reconnect.