We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ does not turn on

  • Hi, I have a problem, I can connect to the omega2 + (I think I broke it).
    First I could not connect to the internet, so use the reset option in the settings menu.
    But I did not solve anything, on the contrary, I still did not connect to the internet and now I also had to configure the omega2 + and as I did not connect download this image:
    But now I can not use it, it does not turn on well, the orange light goes on for 10 seconds, then it blinks rapidly and goes out.
    Probe to connect using the usb cable, but my pc does not detect anything connected.
    I'm using the omega2 + with the arduino dock.

  • Apparently the "Arduino dock" is not a USB device, it merely uses a USB connector for power input.

    So there's nothing for a computer to really recognize.

    Getting a USB<>3v3 serial connection would indeed be very useful for troubleshooting and maintenance, but that board won't provide one.

  • The arduino dock itself has no USB to serial port (mini USB).

    (I think I broke it)

    Don`t be so negative 😉 It happens that there are defective devices in circulation. Take a magnifying glass and play a bit "Sherlock Holmes" @fossette shows you how:

    But you can if you not have a other dock:

  • The observed LED behavior would probably not have been able to happen if the issue was a hardware defect.

    Usual issues are insufficient power supply, corrupted software state, or triggering various software bugs.

  • If you use O2+ with an Arduino Dock 2 then you almost have a serial console too.
    See also those OMEGA_RX, OMEGA_TX, GND pins.
    The serial console is a very useful tool.

    Does the schematic help you?

  • I just got home from work.
    Thanks for the answers, but I do not think it's a hardware problem, because for a moment everything works fine, but then I had the problems I mentioned earlier.

    I think installing the firmware correctly solves the problem, but the AP of the omega does not appear to connect it by wifi and I do not know how to connect the omega2p by serial to the pc to see the output.
    For what lei is related to ports omega_tx and omega_rx, but I do not understand that I have to do exactly since I do not speak English and I do not know much about electronics.

  • Already solved, it was a matter of carefully reading the documentation, connect the OMEGA_TX OMEGA_RX and GND pins to an arduino.
    Then connect both to the pc and for serial monitor I can put the firmware from the USB

    0_1486510265313_Sin título.png

    From there pressing the reset button, the normal boot is interrupted and I can load from the usb

  • Might want to be careful about that - unless there's level translation circuitry in there, you are putting substantial stress on the MT7688 serial pins (input especially) by connecting that 3.3v device to a 5v Arduino.

    There may be a 1K or so resistor between the Arduino's serial converter and its pin, but it's still not the best idea, especially if you aren't sure that resistor is there in your particular case.

    But congrats on getting your board talking!

  • @Chris-Stratton said in Omega2+ does not turn on:

    Might want to be careful about that - unless there's level translation circuitry in there, you are putting substantial stress on the MT7688 serial pins (input especially) by connecting that 3.3v device to a 5v Arduino.

    This is one of the issues I have with the Omega2 as against the Omega1. The Omega1 runs on the same 3.3v but the IO pins were explicitly stated to be 5v tolerant. They play well with Arduino and Arduino shields running on 5v.

    I even produced an Arduino Expansion board that plugs in to the Expansion Dock and provides direct access from the Omega1 to Arduinos and Arduino shields (see https://github.com/KitBishop/Omega-Arduino-Expansion)
    I am probably going to have to redo this to incorporate some level shifters to accommodate the Omega2 3.3v only.

    That said, there are some Arduino Shields that run on 3.3v. There is also an Arduino that itself runs on 3.3v (Arduino Pro 328 - 3.3V/8MHz) while still using the standard Arduino Uno header layout (see https://www.sparkfun.com/products/10914). And finally there are instructions available to convert a standard Arduino Uno to run on 3.3v - see: https://learn.adafruit.com/arduino-tips-tricks-and-techniques/3-3v-conversion

Looks like your connection to Community was lost, please wait while we try to reconnect.