We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

OLED Not working on Plus

  • I received my Omega 2S+, finally got it updated and functioning, now the OLED does not function. I have tried 6 different OLED modules and none of them seem to work, but if I plug them back into an Omega 2+ they work fine. I tried the OLED app in the Legacy console, it also complains "Unable to communicate with selected device".

    My C app reports:

    onion-i2c:: write issue for register 0x80, errno is 6: No such device or address

    Did I miss something? I'm on the latest firmware Version: 0.3.1 b211

  • administrators

    @crispyoz Are you using an Onion OLED Expansion

    or a third party OLED module?

    If you're using the Onion OLED Expansion, have you tried using the oled-exp command line utility?
    More info in oled-exp can be found here.

  • @crispyoz If you are you using a genuine Onion OLED Expansion then connect pin4 to pin3 on its Expansion Header
    and connect the GND, 3.3V, SDA, SCL pins to the GND, 3.3V, SDA, SCL pins of Omega2S+ respectively.

    OLED Expansion Header pinout (top view)
     GND | 1  2|
    3.3V | 3  4| VDD25 / Omega2(+) GPIO11 
         | 5  6|
         | 7  8|
         | 9 10|
         |11 12|
         |13 14|
         |15 16|
         |17 18|
         |19 20|
         |21 22| SCL  GPIO4 Omega2(+)
         |23 24| SDA  GPIO5 Omega2(+)
         |25 26| GND
         |27 28|
     GND |29 30| 3.3V

    Do not forget to remove the pin3-pin4 short circuit if you want to plug the Oled Expansion to any genuine Onion Omega Expansion Header directly because Omega2(+) may be damaged if you set GPIO11 to Low.

    See also:
    Connect oled expansion and omega 2+ only
    Using OLED expansion with other devices

  • Thanks everyone for the replies. I have been using the genuine Onion OLED. I found he issue, the connector seems to have an issue. If I jiggle it, it will start working, then stop working. I tested on 3 different OLEDs and I get the same behaviour so it's definitely my 2S+. I have more on order so hopefully I'll be ok once they arrive.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.