Bad characters on U-boot using UART interface



  • Hi.
    I've got the following problem. I'm trying to flash the firmware from my USB drive. So I press the "Reset" button and see that LED starts blinking. My COM port is opened via Putty. However, I see strange characters although some characters seem to be correct. I'm trying to press "1" or "2" option but without any success.
    0_1559908670568_52e09e18-3bd0-4834-b25c-edbc66a9ec5c-image.png
    When the bootloader is loaded (after 40 seconds) it starts to uncompress image. Then everything is OK.
    0_1559908726725_4c7e1381-a115-4256-bc1c-0b793477d777-image.png
    What is wrong with the UART and bootloader? There is some noise. I've tried to connect UART pins directly with my UART-USB adapter but it didn't help. Also, I'd like to mention that I didn't change the bootloader.



  • @Artem-Kramov
    Assuming you are using an Onion Expansion or Mini dock, are you using the required driver and speed as detailed in Serial on a Windows Device?



  • I'm using the required driver CH340 on my Windows PC



  • @Artem-Kramov
    A while back I had a similar problem. I was using an Omega2+ with a power dock. I had connected the serial via ftdi-usb to my PC with Putty as my terminal. I checked drivers, speed, parity etc. but still had a display just like yours. Eventually it turned out to be a bad ground connection between the dock and ftdi.



  • @Michael-Lynch
    Thank you very much! I'll try your suggestion and respond if it works.



  • @Michael-Lynch
    Sorry for such delay - I was fighting against this problem. Your suggestion was hopeful but it didn't help me. I hope your suggestion will help other people who will face this kind of problem.
    I've suddenly noticed that I can see correct symbols of bootloader output on the baud rate 120000 (instead of expected 115200). However, the baud rate of the kernel has to remain 115200. Firstly I thought that it is a manufacturing defect but I've noticed such a thing on the few devices. Also, I've entered into the console mode of the bootloader: the expected baud rate is 115200 (variable baudrate=115200).
    @Omega-Squad , @administrators @cas
    I'm using Omega2+ devices. What is the reason for this bug? I'm a little bit confused about how to deal with this problem. I hope for your understanding.


  • administrators

    @Artem-Kramov What does your hardware setup look like? Are you using an Expansion Dock or a Mini Dock?



  • @Lazar-Demin OP "told" us a few backround info too

    • he has an Omega2+ with FW ???
    • I guess - he has no dock or maybe has some custom dock
    • he has a CH340 USB-to-serial module / cable, it seems the Omega Tx -> PC Rx connection is broadly OK
    • he has a Windows ??? PC with PuTTY

    I think he has some hardware problem - so the

    What does your hardware setup look like?

    is a very good question.



  • Original poster is right. looks like a bug in the boot ROM. It wants 120,000 baud rate, not 115200.

    Context: Omega2+ in mini-dock, Win10 64 bit, trashed file system, want to go back to factory firmware. Wifi connectivity also trashed.

    Holding the reset button down for 10 seconds does not work, still trying to boot from the micro SD card

    So I wanted to update the firmware from a USB stick, following the procedure in the documentation.

    1. I inserted the USB stick.

    2. Holding down the reset button while turning power on, the serial port disconnects soon after power-up. Only way to recover is disconnect and reconnect USB, but this forces a power cycle. No good in the mini-dock.

    3. Tried the same process in a Linux system, silent failure this time but still no luck.

    4. Move to a Power Dock 2, soldered on a SparkFun Serial Basic card (CH340). Made sure it was jumpered for 3.3V! Pins 1 gnd 5 Tx 6 Rx (seen from serial card end) .

    Note - you can't do this with a mini-dock etc. because your external serial card will be fighting with the internal serial converter chip.

    Now it comes on with reset button held, but screen full of trash for 40 seconds then a normal boot.

    1. Then I came across this comment, inspiring me to try 120000 baud rate instead of 115,200. Works!

    Procedure - set PuTTY for 120,000, power on holding reset button until fast blink, zip over to the keyboard and hit 2 quick as a bunny, system loads from USB stick and then does normal boot. Switch PuTTY back to 115200, hit enter and the prompt shows up.

    Don't know why it skips the log-in or why it needs a carriage return. But that has been my experience with this system using the hardware serial port.

    There seems to be no other way to unbrick a non-WiFi capable Omega2, except maybe if you have an Ethernet dock. Probably same problem trying to use a micro-SD card.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.