We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2+ Wifi unstable and slow

  • @crispyoz Thanks for the reply!

    Do you have a specific command in mind? I also put the omega right next to the router and get the same result. I also tried connecting the omega to my cell phone AP and get the same issue.

    Here are my wifi settings:

    config wifi-device 'radio0'
            option type 'ralink'
            option variant 'mt7628'
            option country 'US'
            option hwmode '11g'
            option htmode 'HT40'
            option channel 'auto'
            option disabled '0'
            option device_mode 'apsta'
            option op_mode 'preference'
    config wifi-iface 'ap'
            option device 'radio0'
            option mode 'ap'
            option network 'wlan'
            option ifname 'ra0'
            option encryption 'psk2'
            option key '12345678'
            option disabled '0'
            option ssid 'Omega-4305'
    config wifi-iface 'sta'
            option device 'radio0'
            option mode 'sta'
            option ifname 'apcli0'
            option encryption 'psk2'
            option network 'wwan'
            option disabled '0'
            option ssid 'Torres 2.4GHz'
            option key 'REDACTED'
            option led 'omega2p:blue:wifi'
    config wifi-config
            option ssid 'Torres 2.4GHz'
            option encryption 'psk2'
            option key 'REDACTED'
    config wifi-config
            option ssid 'AlexyAPS'
            option encryption 'psk2'
            option key 'REDACTED'

  • @Alexy-Torres That looks pretty normal. My first thought is that it seems some users have had issues with their wifi due to some differences with US configuration. Try removing "option country ''US"

  • @crispyoz I tried that but unfortunately I still have the same results. If that could help someone, the issue appeared like 3 days ago and wasn't present 1 week ago.

  • @Alexy-Torres that is interesting. It suggests something has changed. If this happened to me I would do as follows:

    1. Factory reset
    2. Use wifisetup to configure wifi
    3. oupdate

  • @crispyoz I already did. At first I factory reset the omega, then updated the firmware (that was a pain in the ass with this connection issue ahah) and nothing changed.

  • @Alexy-Torres How are you powering your Omega?

  • @crispyoz Through the dock, plugged by USB on my computer, I also tried to plug it to a usb charger directly

  • Just an update, I used the omega today and everything was fine, I don't know what happened...

  • @Alexy-Torres Something I noticed is that the AP mode is using the same channel as my home router so big and random interference might happen from time to time.

    Can you check with any wifi scanner if the AP wifi or your Onion is using the same channel as your home router?


  • Any further updates? This always happens to me from time to time. Sometimes it just resolves itself after I do a full power off and on.

Looks like your connection to Community was lost, please wait while we try to reconnect.