We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2+ Wifi unstable and slow

  • @Alexy-Torres That looks pretty normal. My first thought is that it seems some users have had issues with their wifi due to some differences with US configuration. Try removing "option country ''US"

  • @crispyoz I tried that but unfortunately I still have the same results. If that could help someone, the issue appeared like 3 days ago and wasn't present 1 week ago.

  • @Alexy-Torres that is interesting. It suggests something has changed. If this happened to me I would do as follows:

    1. Factory reset
    2. Use wifisetup to configure wifi
    3. oupdate

  • @crispyoz I already did. At first I factory reset the omega, then updated the firmware (that was a pain in the ass with this connection issue ahah) and nothing changed.

  • @Alexy-Torres How are you powering your Omega?

  • @crispyoz Through the dock, plugged by USB on my computer, I also tried to plug it to a usb charger directly

  • Just an update, I used the omega today and everything was fine, I don't know what happened...

  • @Alexy-Torres Something I noticed is that the AP mode is using the same channel as my home router so big and random interference might happen from time to time.

    Can you check with any wifi scanner if the AP wifi or your Onion is using the same channel as your home router?


  • Any further updates? This always happens to me from time to time. Sometimes it just resolves itself after I do a full power off and on.

  • Hi, and sorry about rebreathing old topic alive.

    I finally got my Omega2+ with Power Doc through 1st Time Setup using the Command line (or somewhat completed it) and got WiFi connection to work to the outside world. Then I went and updated firmware and now I got WiFi connection unstable and slow. šŸ˜ž

    I have owned Omega2+ from the crowdfunding times but haven't got earlier just time to really try it out. Years back I got tired on not getting WiFi to work and didn't have time to solve the problem.

    So what I recently did:

    1. I struggled several days in order to get WiFi connection to work, finally this one solved the WiFi connection problem to WiFi router:
      (Apparently the trick was to set ipv6 '0' in "network" and/or it was related to setting Bssid in "wireless". I'm not sure since my last trial included both additions.)
    2. After 1st Time Setup I decided to update my firmware, since it was very old, before continuing with anything else
    3. After files were downloaded there was a message on rebooting (can't recall anymore exactly what it was) but rebooting did not occurred automatically in 15-20 minutes and I did power reset
    4. Omega2+ boots up but now the WiFi is very unstable I can't get practically anything to work. FW is updated to 0.3.2 b233

    Current status:

    • No connectivity via my WiFi network, only direct connection working but it's unstable and slow
    • Omega-xxxx.local not working now, I need to go directly via
    • My edits on "wireless" and "network" disappeared instead there is new and totally different setups. Files are a lot different where I originally started from to work on functional WiFi connection
    • Some of the commands are missing like aps and ia
    • wifisetup doesn't lead to anywhere, it asks the things, restarts wifimanager but not nothing changes (as it was originally also)
    • Manual editing wireless and network is practically impossible since connection is slow and drops out every now and then (so vi-editor at least exists)
    • Factory reset nor power on/off's do not seem to affect in anyway

    I wonder if I own a brick now. Any advices for a beginner?

  • @Rotenone Can you post your /etc/config/wireless file so we can look.

    I suspect you may have a noisy channel, try changing the channel to a fixed channel, try channel 1, 6 or 11, if one doesn't help try another of these.

    To do this, open /etc/config/wireless find the section "config wifi-device 'radio0'" usually at the top, change the option "option channel 'auto'" to one of these channels, I find 6 is generally a good option.

    Also you can comment out the option " option country 'US'" and see if this helps you.

  • @crispyoz I will make capture when I get back to home today but do notice that WiFi worked like a charm when I did updates according to this:
    https://community.onion.io/topic/1495/can-t-connect-to-hidden-ssid/9 so I doubt noisy channel. WiFi network analyzer doesn't show much disturbance on the channel I'm using the home WiFi. Closest neighbours are 30 meters away.

    Yes, 'US' removal has been the first thing I have done. That was one of the edits that I managed to make in time when I had connection up for short period. What I will make when get back to home is that I will make edits ready and try to copy-paste them at once when I get connection up and running for short period. I wonder why I didn't think of that yesterday.

    Upon unstable WiFi there is also problem with these vanished commands. Like aps, ia and nr would be nice to have.

  • @Rotenone Don't you have a power dock or mini dock so you can connect to terminal?

    Please run wifisetup -v debug then post /tmp/wifidebug.log

Looks like your connection to Community was lost, please wait while we try to reconnect.