We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2 LTE won't connect to LTE network

  • Hello,

    I just received my first Onion device, an Omega2 LTE. I am very happy with the hardware quality but have been totally unable to get the device to connect to my LTE network (EE in the UK). I am totally new to this, but have tried a bunch of stuff including using uqmi to configure the modem and using minicom to send AT commands to the modem to get the status. The modem responds to AT commands, has signal, is connected to EE (although not for data) and has the correct APN stored locally, so I assume it received this when I used o2lte apn.

    After 2 days of trying everything I can think of (can't list ā€“ or even remember ā€“ everything I tried) I have still had no luck. I also ran into the same issue described here, but I don't think this is the cause of my main issue.

    Immediately after rebooting the device following o2lte data disable, ifconfig wwan0 shows the device as having an ipv6 address (although when I look this up online it doesn't seem to be a valid public address). If I then use o2lte data enable to start the data connection, ifconfig wwan0 then shows no IP address. (see attachment)

    The APN settings for my provider include a username and password, and initially I thought this might be the issue. I still haven't been able to work out how to provide these to the modem, although at this point I don't think that is the problem after trying the sim in Android phone. Whilst the APN username and password populated by default on the phone, deleting these didn't prevent the device from connecting to the network.

    Does anybody have any ideas on how I might be able to get my Omega connected to LTE? Would be very grateful for any guidance.

    Thank you! šŸ™‚

    Screenshot 2020-04-28 at 18.58.51.png

  • administrators

    @onioneer Is your device the Omega2 LTE North American model or the Omega2 LTE Global Model?
    If it's the Global Model, the LTE modem module will be labelled EG-25G

  • Hi @Lazar-Demin,

    I have the global model, with the EG25-G module


  • Hi @Lazar-Demin

    Do you have any suggestions on how to sort this? Any help would be much appreciated!

  • administrators

    @onioneer You can try using AT commands to query the modem's status, check the signal strength, and debug the connection.

    The /dev/ttyUSB2 interface is reserved for AT command communication with the modem.

    And the AT command reference for the modem can be found here: https://itbrainpower.net/downloadables/Quectel_EC25_EC21_AT_Commands_Manual_V1.0.pdf

    Start with the AT commands listed under section 6 - Network Service Commands

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.