We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

routing traffic to LTE

  • What is the correct and easy way to route traffic to the cellular modem with the Omega2 LTE when there is no wifi?

    Apn is set, 'o2lte data enable', got an ip address with 'ifconfig wwan0', i can ping from wwan0...

    I disabled wifi on my router for the test and i can't connect to my mosquitto server with node -red or make opkg update or anything network related.


  • For your information, there is a package called mwan3 that can carry out load balancing (auto switch to modem if WiFi not available) on OpenWRT. Sadly, it doesn't seem to be compatible with Onion's build. I hacked around this by modifying the default route of the Onion to whatever gateway the modem connects to for internet on the cellular network. I did not have the Omega2 LTE but rather Omega2 Pro with a modem connected via serial port (3g over PPP).

  • @jupiter8 try ifdown wwan this will disable the wifi device, it should adjust your routes.

    Is your mosquitto server on your local network? If it is then it's unlikely to be available when you're on LTE unless you have configured an external DNS and also you'll need some port mappings on your router, perhaps also firewall changes to permit incoming WAN traffic, since when you're on LTE you are effectively outside your local network.

    Some other stuff to look at and let us know:

    Try ping, if that works then it's probably a DNS issue, so try

    nslookup yahoo.com

    nslookup yahoo.com

    If you get a valid response from the second but not the first then it's your DNS setup, check your /etc/resolv.conf for your name server.

    If the ping doesn't work then it's a routing issue.

  • administrators

Looks like your connection to Community was lost, please wait while we try to reconnect.