We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

In Console, Terminal isn't working

  • In the Console, the Terminal app isn't working. Any idea what's going on? I'm getting an error (probably 404 or similar): image.png

    I typed in the address as shown in the error message, but I get the exact same results. Can anyone tell me what's going on?

    P.S. Yes, my son is responsible for the "Hi Dad" message at the top of the page. Since he's HTML-literate, I'm guessing he modified an index.htm(l) file somewhere, but I haven't found it (yet). I'm very new to Linux, so I'm still muddling through the commands.

  • administrators

    @Jeff-Verive Can you try accessing the terminal via SSH or serial?
    Run the command ps and post the output, we'll use that to ensure the web terminal process is running.

  • My password is not being accepted when logging in through the Console terminal app. I am able to log into the console using 'root' and my new password (e.g., not onioneer.), and serial port communications is working fine; firmware is 0.0.6 b275.

    This behavior is identical on all five of the Omegas I have. What might be the problem?

  • Hi @Seth-Hall, have you tried to load the Terminal app on a different network? Perhaps port 4200 is getting blocked by your network policy?

    Here's something you can try: Connect to the Omega via the Access Point, and login to the console by going to Please let me know if this works.


  • Terminal in Console is working again, so I don't know what the problem might have been. All's well that ends well, I guess!

  • Terminal in NOT working in Internet Explorer or Microsoft Edge, but it does work with Chrome and with Firefox; my computer is a 32-bit Dell Latitude D620 running Windows 10.

    However, the terminal window in Chrome and Firefox is only about 8 or 9 lines. Is there a setting for this? A suitable work-around is to SSH into the Onion through PuTTY, so buggy Terminal doesn't bother me too much. However, since I do like to use the GPIO Tool in the Console, it would be lovely if the Terminal app worked better (and across various browsers).

  • How do you log into terminal? I can't log in! Please help!

  • @Ivan-Yu This thread is over a year old.

    There are new threads that address login issues that are more current and apply to the latest versions of the firmware.

Looks like your connection to Community was lost, please wait while we try to reconnect.