We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Cloning the Omega2LTE image and flashing other devices - Not Working

  • I have been trying to clone the Omega2LTE device after adding custom files and configurations.

    I have inserted an SD card into the device I want to clone and run the dd command. However, after cloning it doesn't seem to keep any files, packages or configuration I set in the device.

    My firmware is on the device I want to clone and all other devices is the same as below:

    BusyBox v1.28.3
    Onion-ware 0.3.3 b251

    I have been trying to follow this tutorial here: https://community.onion.io/topic/4563/faq-is-it-possible-to-clone-the-firmware-running-on-an-omega2-device-and-copy-it-to-other-omega2-units?_=1695311567253

    As far as custom configuration/files I have:
    python3 installed
    python3-pip installed
    custom aliases in /etc/profile
    custom files in the /root directory (such as adc.py, lte.py, etc)

    The command I have been running is:

    cd /mnt/mmcblk0p1
    dd if=/dev/mtd3 of=omega100.bin

    Afterward it spits out an image file and I swap the SD card to a different onion. I then run:
    cd /mnt/mmcblk0p1
    mtd -r write omega100.bin firmware

    The device restarts and yet none of the files are in the /root and python3 is not installed, etc.

    I just want to be able to flash an image to other devices while keeping python3 installed and having the custom files and configurations still set.

  • administrators

    @thomas166 hmm that's strange. To confirm, both the "original" and "clone" Omega2 LTE devices are running the same firmware version initially?

    Can you post the output of the dd if=/dev/mtd3 of=omega100.bin and mtd -r write omega100.bin firmware commands?

  • I am not sure why, but it was not working on my computer/SD card. I tried on a different computer with a different SD card and it worked no problem. 🤷

  • administrators

    @thomas166 glad to hear it worked out.

    I'm a little confused tho, when you say computer, do you mean the Omega2 LTE?

Looks like your connection to Community was lost, please wait while we try to reconnect.