We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[RESOLVED] Onion Omega is not detected on Mac OS X

  • Hi all,

    I'm trying to start playing with my Onion Omega but it is not being detected on my Macbook. I already installed the driver but I don't see any /dev/tty.SLAB_USBtoUART nor the Omega-* SSID. Any advice?

    Davi Garcia

  • I had same problems when i started. The difference was, i have Linux and not OSx.
    Till today i cant use the ttyUSB0 on my Host OS. I had to install a Virtual-Box guest with Solydx. With this Installation i can connect out of the box. I do it as root then it works ... no root gets no connection.

    About not seeing the SSID, i had the problem that my router used an ID higher than ID9. If you could check this on your router ... you have to do this under the settings from Wifi chanel ... not select auto ... better select a ID less than 10 manualy. This worked for me and i can see the omegas now.

    Afterwards i could connect and update as described in onion.io/getstartet

  • administrators

    Yep, follow @Luciano-S.'s advice.

    Can you also post a photo of your setup?

  • Hi @Luciano-S,

    I tried what you said but I think the problem is with the Onion Omega itself. Looks like it is not even recognised by my notebook, so there is no way to map it to my virtual machine. Looks like my device is dead... if so, I'm very frustrated...!

    Screen Shot 2016-05-11 at 2.01.57 PM.png


  • Davi,

    Check to make sure the device is installed correctly with ls /dev/tty.*

    If it lists nothing then there is some problem with your install of the CP2102 driver. Try reinstalling and rebooting. You can't connect until you see the tty device.


  • Hi everybody,

    After tried to do a lot of tests I finally found the problem: the fu*$%&@ USB cable. Problem solved and I'm happy again! ā˜ŗ


  • Hi @Davi-Garcia,

    Thank you for letting us know. We will improve our troubleshooting articles with a comprehensive list of things to try in the future to save you and others some grief šŸ˜›

    In the meantime I'll mark this as resolved.

    Thanks again,


  • @Davi-Garcia said:

    Hi everybody,

    After tried to do a lot of tests I finally found the problem: the fu*$%&@ USB cable. Problem solved and I'm happy again! ā˜ŗ


    Would be nice to know if it was just the cable or you run in problem because of the USB3 port u used on your print screen?!
    Or tell us with witch constellation it worked (witch cable/port version).

    Would be also nice if you change the Title in your first post to:
    [RESOLVED] USB to serial problem (or similar). Because i belief it is not Mac specific.

  • Hi guys,

    Just to complement the post with useful information, with proper functional USB cable the output of System Device Manager:

    0_1463504338265_Screen Shot 2016-05-17 at 13.54.08.png

    The cable is a regular USB-mini cable that came with my Amazon Kindle. The issue was not related with the USB ports of my computer.

    Davi Garcia

  • I had this same issue. I found that a mac or pc could detect the onion but the virtual port would not appear when i used a USB cable less than 12" in length.

  • @Jason-Hamlett said in [RESOLVED] Onion Omega is not detected on Mac OS X:

    I found that a mac or pc could detect the onion but the virtual port would not appear when i used a USB cable less than 12" in length.

    When i was reading this I had to smile. Anyway I changed mine with a longer one and now it works out of the box also with my Host OS. Strange that the same cable worked with the Virtualbox-guest OS!!

    Is there someone who has a technical explanation of this phenomenon?

  • administrators

    Hmm haven't had any issues using short cables before, but I do have a theory as to why some small cables don't work:

    USB data lines need to be twisted pairs that are impedance matched, I think 90 ohms. (This is especially important when routing USB data line traces on a PCB).
    I'm guessing the short cables might have a slightly different impedance than the recommended 90 ohms and that this affects the communication between the USB-to-Serial chip on the Dock and the USB controller.

  • @Lazar-Demin thx for your answer.

    I found some interesting articles by googling:
    USB cable resistance (Especially conclusion on end of article).
    Identifying the Correct USB Cables Type (with picture)

    The first article shows the problematic of charging a battery with power loss because of wrong diameter of the cable who transmits the power.

    The second article mentions beside power loss, side effects of missing isolation.

    My conclusion:
    Shorter cable are better when they have the right diameter and isolation (inside). Mine (charging cable from my new galaxy tablet) works fine now but makes noise in the speakers. Apparently captures the WIFI signal and transmits it to the USB Bus.

    @administrators, might be a good idea to do some tests in the Lab with a maximum of extensions connected. But especially when you start to sell the battery extensions, that they transmit enough energy to load them correct. Probably add one to the online shop could avoid a lot a headache for you šŸ™‚

  • I proposed on Github to add in the get-started tutorial:

    Run ls /dev/tty.* to see if the USB-to-Serial device can be detected. If the driver is successfully installed, you should* be able to see a device with a name similar to /dev/tty.SLAB_USBtoUART.

    *If you can't see the device, a old or to long USB cable could be the problem to. If you use a deskdop computer, use a USB connection on the back (on mainboard) or just try a other/newer cable.

    Same I proposed for Linux.

  • Hi all,

    My issue is as follows: got the same problem using the (new) power dock I found in my mail today. Using this dock, I cannot get the tty to show on my mac. Using the same cable, same mac, same software (driver) it works with the mini dock I have here. So I recon my power dock is (partly) faulty. How do I go about here ?


  • administrators

    Hi @Rudi-van-Drunen
    The Power Dock does not have a USB-to-Serial chip so the Omega cannot be detected as a tty. You will have to access the Omega via SSH.
    We're going to be putting up a wiki article on using the Power Dock in the next few days.

    Also, please read and follow the posting guidelines, your post should be a brand new topic. This way it makes it easier for the team to promptly respond to questions.

  • Seems like I just had a similar issue - short cable did not work, longer cable did.

    My suspicion is that my shorter cable (pulled from my box of cell phone cables) might just have the power wires hooked up and not have all the wires connected.

  • Hi all,
    I am also having trouble connecting to my bricked Omega using serial. I bought a CP2012 breakout, tried using a long USB cable, etc. When I run "screen /dev/tty.SLAB_USBtoUART 115200" I get the same quick 2 error messages about Resources and PTY. I tried running "lsof" and "kill" the process, can't seem to connect. Any ideas? I am using the Power Dock, with the GND connected and the Rx-to-Tx, Tx-to-Rx from the 2102. I am completely stuck, any help would be greatly appreciated.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.