We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[RESOLVED] Why is my Omega just accessible via its IP but not omega-XXXX.local?

  • Hey,
    since I got my Omega 5 month ago I am just able to access it via its IP but not the URL omega-XXXX.local (XXXX is the ID of my Omega of course). I wonder what could be the reason for that? Is there anything I can change to make it accessible via the URL? Are there any other disadvantages of this malfunction?

  • @Peter-Harrald Me too. I have NEVER been able to access my Omega as Omega-XXXX.local and have never figured out why not 😞 I too have had it for over 5 months.
    However, since works fine with no drawbacks (I am aware of), that's what I always use.
    Also, I have a second Omega that I purchased much more recently (about 1 month ago) and it doesn't work with Omega-XXXX.local either 😞
    Because I sometimes want access to both my Omega's simultaneously, I changed the IP address of the second one to to avoid IP address clashes and this works fine

  • @Peter-Harrald did you try without the .local domain?

    If you have older Omegas i think a factory reset would solve the problem. When you update, the /etc/ directory keeps intact and you will keep the old config.

    Mine works, just check and compair the config-file below:

    cat /etc/config/dhcp

    config dnsmasq
            option domainneeded '1'
            option boguspriv '1'
            option filterwin2k '0'
            option localise_queries '1'
            option rebind_protection '1'
            option rebind_localhost '1'
            option local '/lan/'
            option domain 'lan'
            option expandhosts '1'
            option nonegcache '0'
            option authoritative '1'
            option readethers '1'
            option leasefile '/tmp/dhcp.leases'
            option resolvfile '/tmp/resolv.conf.auto'
            option localservice '1'
    config dhcp 'wlan'
            option interface 'wlan'
            option start '100'
            option limit '150'
            option leasetime '12h'
            option dhcpv6 'server'
            option ra 'server'
    config dhcp 'wwan'
            option interface 'wwan'
            option ignore '1'
    config odhcpd 'odhcpd'
            option maindhcp '0'
            option leasefile '/tmp/hosts/odhcpd'
            option leasetrigger '/usr/sbin/odhcpd-update'


  • @Luciano-S Thx for the quick response! My dhcp file looks the same. Connecting with the omega without the .local doesn't work either.
    Any other ideas?

    @Kit-Bishop Sorry to hear that you are facing the same issue. Out of curiosity: Did you ever try to connect to an Omega with the arduino expansion? (Because that's another issue I'm facing and I want to make sure this is not related)

  • @Luciano-S Have just checked too and my /etc/config/dhcp is identical to what you posted yet Omega-XXXX.local doesn't work for me either so it must be something else

    @Peter-Harrald Not a big deal since using the IP address works fine - more just interested as to why Omega-XXXX.local works for some people and not others.
    Regarding connecting with the Arduino Dock - I don't think this is relevant. While I have some issues with the design of the Arduino Dock and how it works, I am regularly able to use if an communicate with the Arduino from the Omega

  • @Peter-Harrald My desktop is connected to Wired Ethernet and wifi is disbaled
    Placing in the browser url section I get this:

    This site can’t be reached took too long to respond.
    Reloading the page
    Checking the connection
    Checking the proxy and the firewall

    If I enter Omega-xxxx-local within the browser url section, the screen shows the log in but once completed and enter is pressed. only the console background splash screen shows and with no icons coming up.

    Now enabling the wifi interface I can access the Omega-xxxx-local console no problems.But access via still yeilds "this site can not be reached.

    I have not spent anytime trying to figure this one out but thought I would share.

  • @Guest said in Why is my Omega just accessible via its IP but not omega-XXXX.local?:

    I have not spent anytime trying to figure this one out but thought I would share.

    OpenWRT is a router os. And a router is routing you from one network to the other. But it not happens without configure it. Remember the wifi tutorial? There you configured that you have access from the wired network to the wireless network (firewall). And if this is still not working, you have to change the net-mask of the two networks for example. If there it is a mask like you cant not reach network addresses like <> With a net-mask like it might work.

  • administrators

    Many Windows users have reported issues using the omega-ABCD.local address.
    It seems that installing Apple's Bonjour service remedies the problem. Try that and let us know!

  • My device is accessible as omega-ABCD.fritz.box. That is because the existing router in my network (a FRITZ!Box router) names it hat way.

  • @Lazar-Demin Installing Apple's Bonjour service solved the problem for me. Thank you! Out of curiosity: Do you have any idea why this makes a difference?

    @Han-Vertegaal lol.. how did you figure that out?

  • @Peter-Harrald said in [RESOLVED] Why is my Omega just accessible via its IP but not omega-XXXX.local?:

    Do you have any idea why this makes a difference?

    For Windows user:

    For Linux user:

    Zeroconf services (except IPv4LL) on Linux are provided by Avahi. Use the distro's normal service mechanisms to start the Avahi daemon. In order to announce services running on the web server you'll need to use something like mod_dnssd that talks to it.

  • administrators

    The Omega uses Avahi (zeroconf) to name the Omega on your local network. Installing Bonjour will allow your windows machine to listen for zeroconf configurations on your network as @Luciano-S mentioned πŸ™‚

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.