We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Flashed wrong firmware

  • Couldn't get onion2 to connect to wifi networks and after trying various fixes suggested in the community I figured I'd flash latest firmware from USB and try again.

    Accidentally downloaded and flashed onion2+ b140 firmware to onion2. Dummy. Now I get fatal exceptions and reboots even when attempting to flash correct firmware. Couldn't figure out much of use in the command line boot menu option. Figure I'm bricked but any ideas would be appreciated.

  • So there's the ethernet option:


    But I'd probably be better off just buying another omega2 since I don't have the ethernet expansion. Anything to be done from the command line boot?

  • Those are the instructions I followed to initially install the incorrect version. Now when I try to do it with the correct version on USB it fails and loops ending with this then restart.

    [ 1.135856] Call Trace:
    [ 1.138339] [<80132f0c>] rq_flush_dcache_pages+0x6c/0x1a0
    [ 1.143818] [<801cf3a4>] mtd_blktrans_work+0x25c/0x3a4
    [ 1.149044] [<800368d0>] process_one_work+0x1f8/0x334
    [ 1.154173] [<800376e4>] worker_thread+0x2b0/0x404
    [ 1.159034] [<8003ba9c>] kthread+0xd8/0xec
    [ 1.163191] [<80004478>] ret_from_kernel_thread+0x14/0x1c
    [ 1.168658]
    [ 1.170164]
    Code: 72822002 8e030050 00831021 <8c520004> 8c440000 02531023 0222902b 0232100b 00409021
    [ 1.180328] ---[ end trace 81cda78ca16c4f04 ]---
    [ 1.186421] Fatal exception: panic in 5 seconds
    [ 6.198977] Kernel panic - not syncing: Fatal exception
    [ 6.205573] Rebooting in 1 seconds..

  • @Barry-Borgleson Well, I guess there isn't anything you can do, then, without the Ethernet-expansion. Sorry.

  • That's what I figured and mostly wanted confirmation that I shouldn't waste time trying to figure it out.

    Totally my fault for downloading the wrong firmware version but still frustrating that wifi never worked to run oupdate.

  • I was able to get the image loaded into memory using the u boot command prompt (option 1 on the boot menu after holding reset during boot). However, I can't boot the image once it's in memory. I get a bad magic number error. Anyone familiar with u boot have recommendations?


  • Bad Magic Number,FFFFFFFF = Blank or NON existent Flash Chip

    Try a USB Upgrade.

    Onion Corporation = Code Bogarts

    Always keep in mind that it is the purpose of the GPL to enable the users to exercise his freedoms.
    Specifically, the freedom to make modified versions of the program, and to run such modified versions of the program.

    Thanks for your contribution to Open Source Software...

  • I loaded the b143 image to memory address 0xBC050000 instead and then was able to boot it from u boot but I got the same fatal exception and reboot which was confusing.

    However, then I tried flashing from USB again and it worked this time so now I'm up and running. Not sure exactly how that worked but learned a bit about u boot.

    Edit: Am now able to connect to wifi without issue as well. This is resolved.

  • administrators

    @Barry-Borgleson glad to hear you got it working!

    @Larry-Pinney lol code bogarts. we have no intention of hoarding source code, but as you can imagine we've been pretty swamped. we will release our source code. thank you for your patience and support

Looks like your connection to Community was lost, please wait while we try to reconnect.