We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+: Editor & Terminal doesn't work in Web-Console v0.1.8 - b145

  • I was trying to launch Editor or Terminal in Safari 10.x. Unfortunately I always receive "TypeError: Attempted to assign to readonly property." [webcomponents.js:978]

    The loading symbol is loading infinitely!

    Any idea how to solve it?

  • Have you tried other browsers to make sure something didn't install properly?

  • @Tyler-Mattioli

    I did some test:

    IE9: won't load the console
    Mozilla Firefox: can open and show the installation.After installing, relogin is required. But Editor and Terminal doesn't work

    iOS Chrome and iOS Safari: won't load at all.

    The console is more an alpha version (not ready).... The only stable way at the moment is SSH (v0.1.8)

  • my first install had loading problems but after i flashed new firmware it worked fine. i would probably flash firmware if i had many load issues. i think there is new beta firmware you could give that a try.. b148 from 1/18/2017

  • @Douglas-Kryder already tried this morning with the latest version. Nothing changed.... even the reboot issue still occurs... getting more issues with Omega2+ than with RPi...

  • @Vinh-Tran Btw, you may try yesterday's firmware build omega2p-v0.1.8-b148.bin. About the Web Console interface, consider it a bonus-extra-feature, and don't rely on it. It's not v1.0 yet. Also, use GitHub to report issues:

  • @fossette I already tried omega2p-v0.1.8-b148.bin

    Web Console Interface is something they should not even advertise within their guideline.

    I'm mostly concerned about the not working sd card slot

  • @Vinh-Tran The SD card works in the latest build As of 142 or something. They just don't have documentation on it. You can find your SD card in /tmp/mounts I believe.

    Also, try to install these packages to fix your issues.

    opkg install onion-console-editor
    opkg install onion-console-terminal

Looks like your connection to Community was lost, please wait while we try to reconnect.