We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Arduino Dock - avrdude: AVR device not responding



  • I have an Onion Omega2 running the latest firmware version. 0.3.2 (b233) which is connected to the Arduino Dock 2.

    I followed the Flashing the Arduino Dock tutorial.

    But when I try to run the Blinky sketch, I get the following error:
    d9dede22-dfb8-4fae-9c3d-e31ac4bbe30b-image.png

    I had a look at the Known Firmware Issues document. Is this the same problem caused by the Cannot flash Arduino Dock if arduino-dock-2 is installed when LEDE package repos are active issue?
    If it is the same issue, I would need to resolve it using Option 2: If already Installed. But one of the steps is: deactivate the LEDE package repos by commenting them out in. My question is how do I identify the LEDE packages that need to be commented out from the list of packages?



  • SOLVED:
    I just made sure it was running the latest firmware and ran the package installation steps again:

    opkg update
    opkg install arduino-dock-2
    


  • @jonty That really is step one when you strike a problem. Install the latest firmware, otherwise you're troubleshooting issues that may already have been fixed.



  • @crispyoz I am using Onion Omega2 with Arduino Dock 2 as well and I am encountering the same Arduino upload error even after updating to the latest firmware and reinstalling the opkg Arduino package. Any suggestions for how I can get over this issue?
    Thanks in advance!



  • @Noniono Please post a screenshot of your :

    1. errors
    2. Firmware version


  • @crispyoz Here are the screenshots of the Arduino IDE showing the "AVR device not responding" error.
    avrdudeError.png

    And I have the latest firmware installed.
    omegaVersion.png

    I have tried Option 2 for deactivating the LEDE package repos mentioned in the Known Firmware Issues doc, but it has not helped with the error.
    LEDEpackages.png

    I have also tried manually flashing the sketch by uploading the precompiled hex file to omega and then flashing through the omega terminal, but that has also not solved the issue.

    This issue came and went earlier, and I chalked it up to the Arduino Dock probably getting overheated. But now the error comes every time I try to upload a sketch. Kindly help me out, please.
    Thank you!



  • @Noniono When you tried to upload hex file via Omega what message did you receive?



  • @crispyoz Manually flashing hex file through the Omega terminal also gives the same error as in the Arduino IDE "AVR device not responding".


  • administrators

    @Noniono Try running opkg list-installed | grep avr to see which version is installed.

    You'll want to have 6.1-1



Looks like your connection to Community was lost, please wait while we try to reconnect.