We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2S+: No WiFi Support with OpenWRT 21.02



  • @crispyoz Do you have a GitHub repo where you've pushed your OpenWrt 22.03 clone with your config changes?
    In fact, If I'm not wrong you git clone the base OpenWrt 22.03 (https://git.openwrt.org/openwrt/openwrt.git)then you've added your feeds and configs right?



  • @IBH My repo is currently private as I am working on something however here as the simple instructions to set up your build system:

    Setup OpenWrt 22.03

    cd
    git clone https://git.openwrt.org/openwrt/openwrt.git openwrt22
    cd openwrt22
    scripts/feeds update -a
    scripts/feeds install -a
    git checkout openwrt-22.03
    make menuconfig
    Target System (MediaTek Ralink MIPS)
    Subtarget (MT76x8 based boards)
    Target Profile (Onion Omega2+)

    Then remove the /etc/config/network and /etc/config/wireless with the settings I gave you earlier in this thread.


  • administrators

    @crispyoz one suggestion:
    do git checkout openwrt-22.03 before scripts/feeds update -a and scripts/feeds install -a

    If you update and install the feeds before changing the branch, you might be using packages meant for the default branch of the openwrt/openwrt repo.
    The feeds.conf.default file points to different branches of the package repositories depending on the branch of openwrt/openwrt.

    See feeds.conf.default in the master branch vs feeds.conf.default in the openwrt-22.03 branch:
    79e2ac85-7e6f-4343-90a6-b8e5ab34313e-image.png



  • @Lazar-Demin @crispyoz thanks both. I got this after doings your steps:
    scripts/config/conf: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.33' not found (required by scripts/config/conf) scripts/config/conf: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.34' not found (required by scripts/config/conf)
    /home/ibh/projects/onion-22-03/sources/openwrt-22/include/toplevel.mk:118: recipe for target 'defconfig' failed
    make: *** [defconfig] Error 1
    FYI: I'm using docker for building.


  • administrators

    @IBH Which docker image are you using?

    If it's the onion/omega2-source docker image mentioned in https://github.com/OnionIoT/source#options-for-using-the-build-system, I would recommend against compiling OpenWRT 21 and 22 with this image since it's based on Ubuntu 18.

    I suggest spinning up a new ubuntu 22.04 container and following OpenWRT's build system setup instructions: https://openwrt.org/docs/guide-developer/toolchain/install-buildsystem



  • @IBH use the command ldd --version to determine which verison of glibc you have installed, you may have to install a newer version. Which OS are you building on? Windows/Linux ? As @Lazar-Demin mentioned you can create your own docker container and follow the OpenWrt instructions, personally I install on my Ubuntu system directly without using docker.



  • @crispyoz @Lazar-Demin Hi both , I'm really disappointed, it doesn't work:
    network file:

    root@OpenWrt:/# cat /etc/init.d/network
    #!/bin/sh /etc/rc.common
    
    START=20
    STOP=90
    
    USE_PROCD=1
    
    init_switch() {
            setup_switch() { return 0; }
    
            include /lib/network
            setup_switch
    }
    
    start_service() {
            init_switch
    
            procd_open_instance
            procd_set_param command /sbin/netifd
            procd_set_param respawn
            procd_set_param watch network.interface
            [ -e /proc/sys/kernel/core_pattern ] && {
                    procd_set_param limits core="unlimited"
            }
            procd_close_instance
    }
    
    reload_service() {
            local rv=0
    
            init_switch
            ubus call network reload || rv=1
            /sbin/wifi reload_legacy
            return $rv
    }
    
    stop_service() {
            /sbin/wifi down
            ifdown -a
            sleep 1
    }
    
    validate_atm_bridge_section()
    {
            uci_validate_section network "atm-bridge" "${1}" \
                    'unit:uinteger:0' \
                    'vci:range(32, 65535):35' \
                    'vpi:range(0, 255):8' \
                    'atmdev:uinteger:0' \
                    'encaps:or("llc", "vc"):llc' \
                    'payload:or("bridged", "routed"):bridged'
    }
    
    validate_route_section()
    {
            uci_validate_section network route "${1}" \
                    'interface:string' \
                    'target:cidr4' \
                    'netmask:netmask4' \
                    'gateway:ip4addr' \
                    'metric:uinteger' \
                    'mtu:uinteger' \
                    'table:or(range(0,65535),string)'
    }
    
    validate_route6_section()
    {
            uci_validate_section network route6 "${1}" \
                    'interface:string' \
                    'target:cidr6' \
                    'gateway:ip6addr' \
                    'metric:uinteger' \
                    'mtu:uinteger' \
                    'table:or(range(0,65535),string)'
    }
    
    validate_rule_section()
    {
            uci_validate_section network rule "${1}" \
                    'in:string' \
                    'out:string' \
                    'src:cidr4' \
                    'dest:cidr4' \
                    'tos:range(0,31)' \
                    'mark:string' \
                    'invert:bool' \
                    'lookup:or(range(0,65535),string)' \
                    'goto:range(0,65535)' \
                    'action:or("prohibit", "unreachable", "blackhole", "throw")'
    }
    
    validate_rule6_section()
    {
            uci_validate_section network rule6 "${1}" \
                    'in:string' \
                    'out:string' \
                    'src:cidr6' \
                    'dest:cidr6' \
                    'tos:range(0,31)' \
                    'mark:string' \
                    'invert:bool' \
                    'lookup:or(range(0,65535),string)' \
                    'goto:range(0,65535)' \
                    'action:or("prohibit", "unreachable", "blackhole", "throw")'
    }
    
    validate_switch_section()
    {
            uci_validate_section network switch "${1}" \
                    'name:string' \
                    'enable:bool' \
                    'enable_vlan:bool' \
                    'reset:bool' \
                    'ar8xxx_mib_poll_interval:uinteger' \
                    'ar8xxx_mib_type:range(0,1)'
    }
    
    validate_switch_vlan()
    {
            uci_validate_section network switch_vlan "${1}" \
                    'device:string' \
                    'vlan:uinteger' \
                    'ports:list(ports)'
    }
    
    service_triggers()
    {
            procd_add_reload_trigger network wireless
    
            procd_open_validate
            validate_atm_bridge_section
            validate_route_section
            [ -e /proc/sys/net/ipv6 ] && validate_route6_section
            validate_rule_section
            [ -e /proc/sys/net/ipv6 ] && validate_rule6_section
            validate_switch_section
            validate_switch_vlan
            procd_close_validate
    }
    
    shutdown() {
            ifdown -a
            sleep 1
    }
    

    Could you please share the config file you've used for your openwrt 22.03 ?
    Could you please this network file maybe I've missed something here?


  • administrators

    @IBH Here are the config files from the Onion-customized 22.03.3 firmware.

    Note that this is the default configuration setup for client mode on ethernet and hosting a WiFi AP.
    To connect to a wifi network, you can follow the WiFi STA section in our technical doc for this firmware.

    Also, keep in mind /etc/init.d/network defines the network service, not the network configuration.


    /etc/config/network:

    config interface 'loopback'
            option device 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd16:9810:ecb2::/48'
    
    config device
            option name 'br-lan'
            option type 'bridge'
    
    config interface 'lan'
            option device 'br-lan'
            option proto 'static'
            option netmask '255.255.255.0'
            option ip6assign '60'
            option ipaddr '192.168.4.1'
    
    config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '0'
    
    config interface 'wan'
            option proto 'dhcp'
            option device 'eth0'
            option hostname 'Omega-f19f'
    
    config interface 'wlan'
            option device 'ra0'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wwan'
            option proto 'dhcp'
            option device 'apcli0'
            option hostname 'Omega-f19f'
    
    

    /etc/config/wireless:

    config wifi-device 'radio0'
            option type 'mac80211'
            option path 'platform/10300000.wmac'
            option band '2g'
            option disabled '0'
            option channel 'auto'
            option htmode 'HT40'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option mode 'ap'
            option ifname 'ra0'
            option network 'wlan'
            option ssid 'Omega-f19f'
            option encryption 'psk2'
            option key '12345678'
    
    config wifi-iface 'client'
            option device 'radio0'
            option network 'wwan'
            option mode 'sta'
            option ssid 'MySSID'
            option key 'MyKey'
            option encryption 'psk2'
            option ifname 'apcli0'
            option disabled '1'
    

    /etc/config/firewall:

    config defaults
            option syn_flood '1'
            option input 'ACCEPT'
            option output 'ACCEPT'
            option forward 'REJECT'
    
    config zone
            option name 'lan'
            list network 'lan'
            list network 'wlan'
            option input 'ACCEPT'
            option output 'ACCEPT'
            option forward 'ACCEPT'
    
    config zone
            option name 'wan'
            list network 'wan'
            list network 'wwan'
            option output 'ACCEPT'
            option masq '1'
            option mtu_fix '1'
            option input 'ACCEPT'
            option forward 'ACCEPT'
    
    config forwarding
            option src 'lan'
            option dest 'wan'
    
    config rule
            option name 'Allow-DHCP-Renew'
            option src 'wan'
            option proto 'udp'
            option dest_port '68'
            option target 'ACCEPT'
            option family 'ipv4'
    
    config rule
            option name 'Allow-Ping'
            option src 'wan'
            option proto 'icmp'
            option icmp_type 'echo-request'
            option family 'ipv4'
            option target 'ACCEPT'
    
    config rule
            option name 'Allow-IGMP'
            option src 'wan'
            option proto 'igmp'
            option family 'ipv4'
            option target 'ACCEPT'
    
    config rule
            option name 'Allow-DHCPv6'
            option src 'wan'
            option proto 'udp'
            option dest_port '546'
            option family 'ipv6'
            option target 'ACCEPT'
    
    config rule
            option name 'Allow-MLD'
            option src 'wan'
            option proto 'icmp'
            option src_ip 'fe80::/10'
            list icmp_type '130/0'
            list icmp_type '131/0'
            list icmp_type '132/0'
            list icmp_type '143/0'
            option family 'ipv6'
            option target 'ACCEPT'
    
    config rule
            option name 'Allow-ICMPv6-Input'
            option src 'wan'
            option proto 'icmp'
            list icmp_type 'echo-request'
            list icmp_type 'echo-reply'
            list icmp_type 'destination-unreachable'
            list icmp_type 'packet-too-big'
            list icmp_type 'time-exceeded'
            list icmp_type 'bad-header'
            list icmp_type 'unknown-header-type'
            list icmp_type 'router-solicitation'
            list icmp_type 'neighbour-solicitation'
            list icmp_type 'router-advertisement'
            list icmp_type 'neighbour-advertisement'
            option limit '1000/sec'
            option family 'ipv6'
            option target 'ACCEPT'
    
    config rule
            option name 'Allow-ICMPv6-Forward'
            option src 'wan'
            option dest '*'
            option proto 'icmp'
            list icmp_type 'echo-request'
            list icmp_type 'echo-reply'
            list icmp_type 'destination-unreachable'
            list icmp_type 'packet-too-big'
            list icmp_type 'time-exceeded'
            list icmp_type 'bad-header'
            list icmp_type 'unknown-header-type'
            option limit '1000/sec'
            option family 'ipv6'
            option target 'ACCEPT'
    
    config rule
            option name 'Allow-IPSec-ESP'
            option src 'wan'
            option dest 'lan'
            option proto 'esp'
            option target 'ACCEPT'
    
    config rule
            option name 'Allow-ISAKMP'
            option src 'wan'
            option dest 'lan'
            option dest_port '500'
            option proto 'udp'
            option target 'ACCEPT'
    


  • @Lazar-Demin I'm not using onion openwrt , I prefer keep using openwrt base and I need to have the .config file I don't know why @crispyoz 's build image worked fine and not mine .


  • administrators

    @IBH These config files should still be helpful. Onion's (beta) Openwrt 22.03 firmware is based on the openwrt base, including the mt76 wifi driver.
    The only customizations so far are different default configurations for better usability out of the box.

    Assuming your firmware has been built properly, the config files from my previous post should setup:

    1. the ethernet port to act as a DHCP client
    2. the WiFi AP to broadcast

    And will allow you to use a few uci commands to connect to an existing Wifi network.



  • @Lazar-Demin Hi, my need is to connect my phone/my laptop etc to my onion wifi and not to connect my onion to wifi .



  • @IBH please add the to the top of your PROCD_DEBUG=1 /etc/init.d/network (after the shebang) and then run service network restart, then run logread and check for errors


  • administrators

    @IBH said in Omega 2S+: No WiFi Support with OpenWRT 21.02:

    my need is to connect my phone/my laptop etc to my onion wifi and not to connect my onion to wifi .

    Like I said above, the configuration in the config files I shared will enable the Omega's WiFi AP.

    If they don't work out of the box, I suggest following @crispyoz's suggestion.



  • @Lazar-Demin @crispyoz , sorry for the delay , I was busy with some other projects.
    I've tried @crispyoz 's suggestion and I got this output :

    root@OpenWrt:/# service network restart
    { "name": "network" }
    [  226.822353] rt3050-esw 10110000.esw: port 0 link down
    { "name": "network", "script": "\/etc\/init.d\/network", "instances": { "instance1": { "command": [ "\/sbin\/netifd" ], "respawn": [ "3600", "5", "5" ], "watch": [ "network.interface" ], "limits": { "core": "unlimited" } } }, "triggers": [ [ "config.change", [ "if", [ "eq",
     "package", "network" ], [ "run_script", "\/etc\/init.d\/network", "reload" ] ], 1000 ], [ "config.change", [ "if", [ "eq", "package", "wireless" ], [ "run_script", "\/etc\/init.d\/network", "reload" ] ], 1000 ] ], "validate": [ { "package": "network", "type": "atm-bridge",
     "data": { "unit": "uinteger", "vci": "range(32, 65535)", "vpi": "range(0, 255)", "atmdev": "uinteger", "encaps": "or(llc, vc)", "payload": "or(bridged, routed)" } }, { "package": "network", "type": "route", "data": { "interface": "string", "target": "cidr4", "netmask": "ne
    tmask4", "gateway": "ip4addr", "metric": "uinteger", "mtu": "uinteger", "table": "or(range(0,65535),string)" } }, { "package": "network", "type": "route6", "data": { "interface": "string", "target": "cidr6", "gateway": "ip6addr", "metric": "uinteger", "mtu": "uinteger", "ta
    ble": "or(range(0,65535),string)" } }, { "package": "network", "type": "rule", "data": { "in": "string", "out": "string", "src": "cidr4", "dest": "cidr4", "tos": "range(0,31)", "mark": "string", "invert": "bool", "lookup": "or(range(0,65535),string)", "goto": "range(0,65535
    )", "action": "or(prohibit, unreachable, blackhole, throw)" } }, { "package": "network", "type": "rule6", "data": { "in": "string", "out": "string", "src": "cidr6", "dest": "cidr6", "tos": "range(0,31)", "mark": "string", "invert": "bool", "lookup": "or(range(0,65535),strin
    g)", "goto": "range(0,65535)", "action": "or(prohibit, unreachable, blackhole, throw)" } }, { "package": "network", "type": "switch", "data": { "name": "string", "enable": "bool", "enable_vlan": "bool", "reset": "bool", "ar8xxx_mib_poll_interval": "uinteger", "ar8xxx_mib_ty
    pe": "range(0,1)" } }, { "package": "network", "type": "switch_vlan", "data": { "device": "string", "vlan": "uinteger", "ports": "list(ports)" } } ], "data": { } }
    root@OpenWrt:/# [  231.143315] rt3050-esw 10110000.esw: port 0 link up
    
    root@OpenWrt:/# logread
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.000000] Linux version 5.10.176 (ibenhassen@beast) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 11.2.0 r0+20130-31b1366bc6) 11.2.0, GNU ld (GNU Binutils) 2.37) #0 Sun Apr 23 12:15:54 2023
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Board has DDR2
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Analog PMU set to hw control
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Digital PMU set to hw control
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] SoC Type: MediaTek MT7688 ver:1 eco:2
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] printk: bootconsole [early0] enabled
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] MIPS: machine is Onion Omega2+
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Initrd not found or empty - disabling initrd
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Zone ranges:
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Movable zone start for each node
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Early memory node ranges
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.000000] On node 0 totalpages: 32768
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.000000]   Normal zone: 256 pages used for memmap
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.000000]   Normal zone: 0 pages reserved
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.000000]   Normal zone: 32768 pages, LIFO batch:7
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.000000] pcpu-alloc: [0] 0
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32512
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Writing ErrCtl register=00070c90
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Readback ErrCtl register=00070c90
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] Memory: 121980K/131072K available (4815K kernel code, 588K rwdata, 1068K rodata, 1200K init, 195K bss, 9092K reserved, 0K cma-reserved)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] NR_IRQS: 256
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] intc: using register map from devicetree
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] CPU Clock: 580MHz
    Sun Apr 23 12:24:41 2023 kern.crit kernel: [    0.000000] timer_probe: no matching timers found
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.000011] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.007649] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.073596] pid_max: default: 32768 minimum: 301
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.078230] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.085248] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.094860] dyndbg: Ignore empty _ddebug table in a CONFIG_DYNAMIC_DEBUG_CORE build
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.106325] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.115824] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.122395] pinctrl core: initialized pinctrl subsystem
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.129155] NET: Registered protocol family 16
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.204262] clocksource: Switched to clocksource MIPS
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.210487] NET: Registered protocol family 2
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.215020] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.222708] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.230834] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.238205] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.245004] TCP: Hash tables configured (established 1024 bind 1024)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.251296] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.257628] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.264672] NET: Registered protocol family 1
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.268852] PCI: CLS 0 bytes, default 32
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.279760] workingset: timestamp_bits=30 max_order=15 bucket_order=0
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.290237] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.295892] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.308468] mt7621_gpio 10000600.gpio: registering 32 gpios
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.314066] mt7621_gpio 10000600.gpio: registering 32 gpios
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.319760] mt7621_gpio 10000600.gpio: registering 32 gpios
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.325504] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.332760] printk: console [ttyS0] disabled
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.337006] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.345742] printk: console [ttyS0] enabled
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.354135] printk: bootconsole [early0] disabled
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.364594] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.374440] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2500000) is a 16550A
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.384945] spi-mt7621 10000b00.spi: sys_freq: 193333333
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.406004] ------------[ cut here ]------------
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.410736] WARNING: CPU: 0 PID: 1 at drivers/mtd/spi-nor/core.c:3008 spi_nor_init+0x1b8/0x1c0
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.419548] enabling reset hack; may not recover from unexpected reboots
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.426351] Modules linked in:
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.429464] CPU: 0 PID: 1 Comm: swapper Not tainted 5.10.176 #0
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.435484] Stack : 80640000 80559874 00000000 00000000 80c1b9e4 80780000 805d0000 80535428
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.443986]         80c282fc 805c9d07 807833b4 00000001 807b0000 00000001 80c1b998 e6063e0c
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.452495]         00000000 00000000 80535428 80c1b838 ffffefff 00000000 00000000 ffffffea
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.461002]         00000000 80c1b844 0000004d 805d0098 00000000 00000009 80c1ba78 802e8aa0
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.469509]         00000009 807b0000 808b4acc 80ce1200 00000018 802ae0dc 00000000 80780000
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.478016]         ...
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.480501] Call Trace:
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.483003] [<80007240>] show_stack+0x30/0x100
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.487534] [<80026ab8>] __warn+0xb0/0x11c
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.491694] [<80026bb0>] warn_slowpath_fmt+0x8c/0xac
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.496748] [<802e8aa0>] spi_nor_init+0x1b8/0x1c0
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.501524] [<802e9a78>] spi_nor_scan+0x6e0/0xb1c
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.506311] [<802e9f48>] spi_nor_probe+0x94/0x314
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.511092] [<802be3e0>] really_probe+0x108/0x4d8
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.515877] [<802bc048>] bus_for_each_drv+0x70/0xb0
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.520829] [<802be9e4>] __device_attach+0x114/0x1cc
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.525880] [<802bd350>] bus_probe_device+0xa0/0xbc
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.530852] [<802b8fc0>] device_add+0x390/0x7a8
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.535464] [<802f1e28>] spi_add_device+0xc0/0x1c8
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.540327] [<802f2868>] spi_register_controller+0x7fc/0xb34
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.546089] [<802f4e24>] mt7621_spi_probe+0x190/0x1e8
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.551223] [<802c0794>] platform_drv_probe+0x28/0x80
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.556362] [<802be3e0>] really_probe+0x108/0x4d8
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.561138] [<802bef18>] device_driver_attach+0x124/0x134
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.566627] [<802befa4>] __driver_attach+0x7c/0x158
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.571578] [<802bbf9c>] bus_for_each_dev+0x68/0xa4
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.576539] [<802bd624>] bus_add_driver+0x150/0x238
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.581490] [<802bf788>] driver_register+0x98/0x154
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.586452] [<80000638>] do_one_initcall+0x50/0x1b4
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.591416] [<80654f3c>] kernel_init_freeable+0x1e0/0x278
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.596921] [<804ad028>] kernel_init+0x10/0xf8
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.601436] [<800026b8>] ret_from_kernel_thread+0x14/0x1c
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.606922]
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.608476] ---[ end trace 0fd428f03a722194 ]---
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.613644] spi-nor spi0.0: w25q256 (32768 Kbytes)
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.618649] 4 fixed-partitions partitions found on MTD device spi0.0
    Sun Apr 23 12:24:41 2023 kern.err kernel: [    0.625185] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
    Sun Apr 23 12:24:41 2023 kern.err kernel: [    0.632626] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
    Sun Apr 23 12:24:41 2023 kern.err kernel: [    0.640649] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
    Sun Apr 23 12:24:41 2023 kern.err kernel: [    0.648145] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.655840] Creating 4 MTD partitions on "spi0.0":
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.660727] 0x000000000000-0x000000030000 : "u-boot"
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.668806] 0x000000030000-0x000000040000 : "u-boot-env"
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.675479] 0x000000040000-0x000000050000 : "factory"
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.683310] 0x000000050000-0x000002000000 : "firmware"
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.690009] 2 uimage-fw partitions found on MTD device firmware
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.696101] Creating 2 MTD partitions on "firmware":
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.701155] 0x000000000000-0x0000001ed974 : "kernel"
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.706212] mtd: partition "kernel" doesn't end on an erase/write block -- force read-only
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.717277] 0x0000001ed974-0x000001fb0000 : "rootfs"
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.722333] mtd: partition "rootfs" doesn't start on an erase/write block boundary -- force read-only
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.732822] mtd: setting mtd5 (rootfs) as root device
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.738970] 1 squashfs-split partitions found on MTD device rootfs
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    0.745329] 0x0000006a0000-0x000001fb0000 : "rootfs_data"
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.802421] rt3050-esw 10110000.esw: mediatek esw at 0xb0110000, irq 25 initialized
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.811181] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.821563] NET: Registered protocol family 10
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.831182] Segment Routing with IPv6
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.835153] NET: Registered protocol family 17
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.839738] 8021q: 802.1Q VLAN Support v1.8
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.852252] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.866371] Freeing unused kernel memory: 1200K
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    0.870968] This architecture does not have kernel memory protection.
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    0.877553] Run /sbin/init as init process
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.881702]   with arguments:
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.881708]     /sbin/init
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.881713]   with environment:
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.881719]     HOME=/
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [    0.881725]     TERM=linux
    Sun Apr 23 12:24:41 2023 user.info kernel: [    1.588563] init: Console is alive
    Sun Apr 23 12:24:41 2023 user.info kernel: [    1.592604] init: - watchdog -
    Sun Apr 23 12:24:41 2023 user.info kernel: [    2.975806] kmodloader: loading kernel modules from /etc/modules-boot.d/*
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.111035] usbcore: registered new interface driver usbfs
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.116809] usbcore: registered new interface driver hub
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.122307] usbcore: registered new device driver usb
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.135729] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.145019] ohci-platform: OHCI generic platform driver
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.160843] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.167661] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.172960] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.179885] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 1
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.188066] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.269389] hub 1-0:1.0: USB hub found
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    3.274013] hub 1-0:1.0: 1 port detected
    Sun Apr 23 12:24:41 2023 user.info kernel: [    3.328227] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    3.336343] mtk-sd 10130000.sdhci: no support for card's volts
    Sun Apr 23 12:24:41 2023 kern.err kernel: [    3.342280] mmc0: error -22 whilst initialising SDIO card
    Sun Apr 23 12:24:41 2023 user.info kernel: [    3.358399] init: - preinit -
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    5.087218] rt3050-esw 10110000.esw: port 0 link up
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    5.530614] random: jshn: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    5.652248] random: jshn: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    5.795673] random: jshn: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    6.247207] mtk-sd 10130000.sdhci: no support for card's volts
    Sun Apr 23 12:24:41 2023 kern.err kernel: [    6.253151] mmc0: error -22 whilst initialising SDIO card
    Sun Apr 23 12:24:41 2023 kern.info kernel: [    6.292357] rt3050-esw 10110000.esw: port 0 link down
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [    6.562609] random: procd: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [    7.651094] mtk-sd 10130000.sdhci: no support for card's volts
    Sun Apr 23 12:24:41 2023 kern.err kernel: [    7.657096] mmc0: error -22 whilst initialising SDIO card
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   10.523205] rt3050-esw 10110000.esw: port 0 link up
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   10.528247] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [   11.030911] jffs2: notice: (404) jffs2_build_xattr_subsystem: complete building xattr subsystem, 9 of xdatum (0 unchecked, 4 orphan) and 10 of xref (4 dead, 0 orphan) found.
    Sun Apr 23 12:24:41 2023 user.info kernel: [   11.048668] mount_root: switching to jffs2 overlay
    Sun Apr 23 12:24:41 2023 kern.warn kernel: [   11.057068] overlayfs: upper fs does not support tmpfile.
    Sun Apr 23 12:24:41 2023 user.info kernel: [   11.125618] procd: - early -
    Sun Apr 23 12:24:41 2023 user.info kernel: [   11.128989] procd: - watchdog -
    Sun Apr 23 12:24:41 2023 user.info kernel: [   12.102568] procd: - watchdog -
    Sun Apr 23 12:24:41 2023 user.info kernel: [   12.107728] procd: - ubus -
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [   12.251561] random: ubusd: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [   12.260828] random: ubusd: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [   12.273591] random: ubusd: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 user.info kernel: [   12.284401] procd: - init -
    Sun Apr 23 12:24:41 2023 user.info kernel: [   13.032741] kmodloader: loading kernel modules from /etc/modules.d/*
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   13.412169] Loading modules backported from Linux version v5.15.92-0-ge515b9902f5f
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   13.419936] Backport generated by backports.git v5.15.92-1-0-gdfe0f60c
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   13.480669] xt_time: kernel timezone is -0000
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   13.567250] mt76_wmac 10300000.wmac: ASIC revision: 76280001
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   14.597061] mt76_wmac 10300000.wmac: Firmware Version: 20151201
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   14.603094] mt76_wmac 10300000.wmac: Build Time: 20151201183641
    Sun Apr 23 12:24:41 2023 kern.info kernel: [   14.624269] mt76_wmac 10300000.wmac: firmware init done
    Sun Apr 23 12:24:41 2023 kern.debug kernel: [   14.805447] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
    Sun Apr 23 12:24:41 2023 user.info kernel: [   15.076826] kmodloader: done loading kernel modules from /etc/modules.d/*
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [   16.836499] random: jshn: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [   16.959104] random: ubusd: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:41 2023 kern.notice kernel: [   16.966053] random: ubus: uninitialized urandom read (4 bytes read)
    Sun Apr 23 12:24:42 2023 user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
    Sun Apr 23 12:24:42 2023 user.notice dnsmasq: Allowing 127.0.0.0/8 responses
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: started, version 2.86 cachesize 150
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: DNS service limited to local subnets
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: UBus support enabled: connected to system bus
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: using only locally-known addresses for test
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: using only locally-known addresses for onion
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: using only locally-known addresses for localhost
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: using only locally-known addresses for local
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: using only locally-known addresses for invalid
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: using only locally-known addresses for bind
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: using only locally-known addresses for lan
    Sun Apr 23 12:24:43 2023 daemon.warn dnsmasq[884]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: read /etc/hosts - 4 addresses
    Sun Apr 23 12:24:43 2023 daemon.info dnsmasq[884]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
    Sun Apr 23 12:24:48 2023 kern.notice kernel: [   24.834290] random: crng init done
    Sun Apr 23 12:24:48 2023 kern.notice kernel: [   24.837768] random: 48 urandom warning(s) missed due to ratelimiting
    Sun Apr 23 12:24:48 2023 authpriv.info dropbear[948]: Not backgrounding
    Sun Apr 23 12:24:52 2023 kern.info kernel: [   29.412355] rt3050-esw 10110000.esw: port 0 link down
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: bonding
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: 8021ad
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: 8021q
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: macvlan
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: veth
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: bridge
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: Network device
    Sun Apr 23 12:24:53 2023 user.notice : Added device handler type: tunnel
    Sun Apr 23 12:24:56 2023 kern.info kernel: [   33.517252] rt3050-esw 10110000.esw: port 0 link up
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Interface 'loopback' is enabled
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Interface 'loopback' is setting up now
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Interface 'loopback' is now up
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Interface 'wan' is enabled
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Network device 'lo' link is up
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Interface 'loopback' has link connectivity
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Network device 'eth0' link is up
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Interface 'wan' has link connectivity
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: Interface 'wan' is setting up now
    Sun Apr 23 12:24:59 2023 daemon.notice netifd: wan (1395): udhcpc: started, v1.35.0
    Sun Apr 23 12:25:00 2023 daemon.info procd: - init complete -
    Sun Apr 23 12:25:01 2023 daemon.notice netifd: wan (1395): udhcpc: broadcasting discover
    Sun Apr 23 12:25:01 2023 daemon.notice netifd: radio0 (1361): sh: acs_survey: out of range
    Sun Apr 23 12:25:01 2023 daemon.notice netifd: radio0 (1361): sh: acs_survey: out of range
    Sun Apr 23 12:25:02 2023 daemon.notice netifd: radio0 (1361): ./mac80211.sh: eval: line 573: /usr/sbin/hostapd: not found
    Sun Apr 23 12:25:02 2023 daemon.notice netifd: Interface 'wlan' is enabled
    Sun Apr 23 12:25:02 2023 daemon.notice netifd: Interface 'wlan' is setting up now
    Sun Apr 23 12:25:02 2023 daemon.notice netifd: Interface 'wlan' is now up
    Sun Apr 23 12:25:03 2023 user.notice firewall: Reloading firewall due to ifup of wlan (ra0)
    Sun Apr 23 12:25:04 2023 daemon.notice netifd: wan (1395): udhcpc: broadcasting discover
    Sun Apr 23 12:25:07 2023 daemon.notice netifd: wan (1395): udhcpc: broadcasting discover
    Sun Apr 23 12:25:32 2023 daemon.notice netifd: radio0 (1361): Command failed: Request timed out
    Sun Apr 23 12:25:32 2023 daemon.notice netifd: radio0 (1361): Command failed: Not found
    Sun Apr 23 12:25:32 2023 daemon.notice netifd: radio0 (1361): Device setup failed: HOSTAPD_START_FAILED
    Sun Apr 23 12:25:32 2023 daemon.notice netifd: Wireless device 'radio0' set retry=0
    Sun Apr 23 12:25:32 2023 daemon.crit netifd: Wireless device 'radio0' setup failed, retry=0
    Sun Apr 23 12:25:32 2023 daemon.notice netifd: Wireless device 'radio0' is now down
    Sun Apr 23 12:28:08 2023 daemon.notice netifd: Interface 'loopback' is now down
    Sun Apr 23 12:28:08 2023 daemon.notice netifd: Interface 'loopback' is disabled
    Sun Apr 23 12:28:08 2023 daemon.notice netifd: Network device 'lo' link is down
    Sun Apr 23 12:28:08 2023 daemon.notice netifd: Interface 'loopback' has link connectivity loss
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: Interface 'wlan' is now down
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: Interface 'wlan' is disabled
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: wan (1395): udhcpc: received SIGTERM
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: wan (1395): udhcpc: entering released state
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: wan (1395): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wan" } (Permission denied)
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: Interface 'wan' is now down
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: Interface 'wan' is disabled
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: Network device 'eth0' link is down
    Sun Apr 23 12:28:09 2023 daemon.notice netifd: Interface 'wan' has link connectivity loss
    Sun Apr 23 12:28:10 2023 kern.info kernel: [  226.822353] rt3050-esw 10110000.esw: port 0 link down
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: bonding
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: 8021ad
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: 8021q
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: macvlan
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: veth
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: bridge
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: Network device
    Sun Apr 23 12:28:11 2023 user.notice : Added device handler type: tunnel
    Sun Apr 23 12:28:11 2023 daemon.notice procd: /etc/init.d/network: { "name": "network" }
    Sun Apr 23 12:28:14 2023 kern.info kernel: [  231.143315] rt3050-esw 10110000.esw: port 0 link up
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Interface 'loopback' is enabled
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Interface 'loopback' is setting up now
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Interface 'loopback' is now up
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Interface 'wan' is enabled
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Network device 'lo' link is up
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Interface 'loopback' has link connectivity
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Network device 'eth0' link is up
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Interface 'wan' has link connectivity
    Sun Apr 23 12:28:14 2023 daemon.notice netifd: Interface 'wan' is setting up now
    Sun Apr 23 12:28:15 2023 daemon.notice netifd: wan (1869): udhcpc: started, v1.35.0
    Sun Apr 23 12:28:15 2023 daemon.notice netifd: wan (1869): udhcpc: broadcasting discover
    Sun Apr 23 12:28:16 2023 daemon.notice netifd: radio0 (1846): sh: acs_survey: out of range
    Sun Apr 23 12:28:16 2023 daemon.notice netifd: radio0 (1846): sh: acs_survey: out of range
    Sun Apr 23 12:28:17 2023 daemon.notice netifd: radio0 (1846): ./mac80211.sh: eval: line 573: /usr/sbin/hostapd: not found
    Sun Apr 23 12:28:18 2023 daemon.notice netifd: wan (1869): udhcpc: broadcasting discover
    Sun Apr 23 12:28:21 2023 daemon.notice netifd: wan (1869): udhcpc: broadcasting discover
    root@OpenWrt:/# 
    

    I think hostapd needs to be added to the build image right?
    Thank you so much for you both , for your time and suggestions.



  • @IBH said in Omega 2S+: No WiFi Support with OpenWRT 21.02:

    image right

    @crispyoz I've managed and fixed the issue by getting the hostapd, the wifi is up now , I can my SSSID in the list of the WiFi but I couldn't connect on it . Do I need to make some other configuration?
    MicrosoftTeams-image (24).png
    This my wifi status:

    root@OpenWrt:/# wifi status
    {
    	"radio0": {
    		"up": true,
    		"pending": false,
    		"autostart": true,
    		"disabled": false,
    		"retry_setup_failed": false,
    		"config": {
    			"path": "platform/10300000.wmac",
    			"channel": "1",
    			"band": "2g",
    			"htmode": "HT20",
    			"disabled": false
    		},
    		"interfaces": [
    			{
    				"section": "default_radio0",
    				"ifname": "wlan0",
    				"config": {
    					"mode": "ap",
    					"ssid": "OpenWrt",
    					"encryption": "none",
    					"network": [
    						"lan"
    					],
    					"mode": "ap"
    				},
    				"vlans": [
    					
    				],
    				"stations": [
    					
    				]
    			}
    		]
    	}
    }
    
    


  • @IBH When you try to connect to the hotspot and it fails, what error are you getting? type logread and look for any errors reported by hostapd.



  • @crispyoz I got this:

    Sun Apr 23 12:18:53 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:19:12 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:19:12 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: disassociated
    Sun Apr 23 12:19:13 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
    Sun Apr 23 12:19:24 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: authenticated
    Sun Apr 23 12:19:24 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: associated (aid 1)
    Sun Apr 23 12:19:24 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:19:45 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:19:45 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: authenticated
    Sun Apr 23 12:19:45 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: associated (aid 1)
    Sun Apr 23 12:19:45 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:22:32 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:22:32 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: disassociated
    Sun Apr 23 12:22:33 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
    Sun Apr 23 12:22:39 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: authenticated
    Sun Apr 23 12:22:39 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: associated (aid 1)
    Sun Apr 23 12:22:39 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:22:51 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:22:51 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: disassociated
    Sun Apr 23 12:22:52 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
    
    


  • @crispyoz I could now connect to the OpenWrt ssid but with no internet connection. Do you have any idea please why?
    There is my logs:

    Sun Apr 23 12:36:15 2023 kern.info kernel: [ 1010.402205] br-lan: port 2(wlan0) entered blocking state
    Sun Apr 23 12:36:15 2023 kern.info kernel: [ 1010.408376] br-lan: port 2(wlan0) entered disabled state
    Sun Apr 23 12:36:15 2023 kern.info kernel: [ 1010.415584] device wlan0 entered promiscuous mode
    Sun Apr 23 12:36:15 2023 kern.info kernel: [ 1010.571804] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    Sun Apr 23 12:36:15 2023 kern.info kernel: [ 1010.578739] br-lan: port 2(wlan0) entered blocking state
    Sun Apr 23 12:36:15 2023 kern.info kernel: [ 1010.585353] br-lan: port 2(wlan0) entered forwarding state
    Sun Apr 23 12:36:15 2023 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->ENABLED
    Sun Apr 23 12:36:15 2023 daemon.notice hostapd: wlan0: AP-ENABLED
    Sun Apr 23 12:36:17 2023 daemon.notice netifd: Wireless device 'radio0' is now up
    Sun Apr 23 12:36:17 2023 daemon.notice netifd: Network device 'wlan0' link is up
    Sun Apr 23 12:36:18 2023 daemon.err onionApp[5184]: + exec
    Sun Apr 23 12:36:20 2023 daemon.info dnsmasq[2786]: read /etc/hosts - 4 addresses
    Sun Apr 23 12:36:20 2023 daemon.info dnsmasq[2786]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
    Sun Apr 23 12:36:20 2023 daemon.info dnsmasq[2786]: read /tmp/hosts/odhcpd - 0 addresses
    Sun Apr 23 12:36:20 2023 daemon.info dnsmasq-dhcp[2786]: read /etc/ethers - 0 addresses
    Sun Apr 23 12:36:28 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: authenticated
    Sun Apr 23 12:36:28 2023 daemon.info hostapd: wlan0: STA fa:89:87:9c:e5:ee IEEE 802.11: associated (aid 1)
    Sun Apr 23 12:36:28 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED fa:89:87:9c:e5:ee
    Sun Apr 23 12:36:28 2023 daemon.info dnsmasq-dhcp[2786]: DHCPREQUEST(br-lan) 192.168.3.225 fa:89:87:9c:e5:ee
    Sun Apr 23 12:36:28 2023 daemon.info dnsmasq-dhcp[2786]: DHCPACK(br-lan) 192.168.3.225 fa:89:87:9c:e5:ee
    root@OpenWrt:/# 
    
    

    MicrosoftTeams-image (26).png MicrosoftTeams-image (25).png





  • @crispyoz Hi, I don't have the wifisetup command :
    root@OpenWrt:/# wifisetup
    /bin/ash: wifisetup: not found



Looks like your connection to Community was lost, please wait while we try to reconnect.