We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

New Firmware, No Wifi, Maybe New Name? Omega2+ 03.2-20230330.bin

  • Board: Omega2+
    Firmware: 03.2-20230330.bin

    Downloaded the new firmware.

    No Wifi setup
    Ran dmesg --> posted the pictures below
    Don't know what I am looking for

    Side note: After updating the firmware, my onion's name is pseudo changed. As you can see in the picture below, it shows the original name: Omega-34EB (Top Left), but in my wifi network on my laptop it now shows as Omega-34ed.

    Is that normal?

    Pictures Below
    Change in Name, and No Wifi.png

    dmesg P2.png

    dmesg P3.png

  • This post is deleted!

  • administrators

    @Amalee What you're seeing is expected. The new firmware that's based on OpenWRT 22.03 uses the open source mt76 wifi driver and not the wifi-warp-core driver, meaning:

    • You won't see the wifi warp core ascii art in the kernel messages
    • The wifisetup utility is not included in the new firmware - you'll need to use UCI to configure the wifi settings
    • The Omega will no longer automatically switch between known wifi networks

    As an aside: in your first screenshot, you ran /etc/config/network and /etc/config/firewall on the command line and got permission denied errors. This is because /etc/config/network and /etc/config/firewall are configuration files that cannot be executed - you can try opening them using vi.
    If you're looking for the network and firewall service executables (that can be used to start/stop/restart the two services), they are at /etc/init.d/network and /etc/init.d/firewall

    To configure the Omega's wifi connection, follow the instructions here: https://github.com/OnionIoT/OpenWRT-Packages/blob/openwrt-22.03/technical-doc.md#wireless-networking

    The naming change is also unexpected, we'll need to look into that!
    Can you please create an issue using the Bug Report template on github so we can better track this?

  • Hey Lazar,

    Thank you for replying. I followed the instructions in the link.
    The open source mt76 driver is used for wireless networking.

    By default, Omega2 will host an AP (Access Point) network. It will be named Omega-abcd where abcd matches the last four digits of the device’s MAC address

    To disable the AP:

    uci set wireless.default_radio0.disabled='1'
    uci commit wireless

    After the last line Putty freezes, and the Omega refuses to connect for more than a couple of seconds. I reset it a couple of times, and tried same results.

    Then I tried the STA commands, but it says ~ash: wireless not found, and then I tried AP again. It freezes after the last command and refuses to connect for more than a couple of seconds. I eventually get the PuTTY Fatal Error (Network error: Software caused connection to abort).


  • administrators

    @Amalee are you connected to the Omega over SSH or serial?
    If it's SSH, then it's expected the connection will drop after you make changes to the wifi configuration.

    Try connecting through serial and trying again: https://github.com/OnionIoT/OpenWRT-Packages/blob/openwrt-22.03/technical-doc.md#connecting-to-the-device

  • This post is deleted!

  • After a stupid amount of work to get the Onion to popup again in the wifi network bank, and then another stupid amount of work to get the ports turned on in my device manager, after downloading and installing https://www.silabs.com/Support Documents/Software/CP210x_VCP_Windows.zip - it still won't recognize it. I can't connect.

    I can't even get it back to a previous firmware since I need to connect via serial.

    Technically, I have an ethernet shield, but that has not worked.

    The Onion has really soured my experience with development boards.

    Everything from Day 1 all those years ago has been cumbersome and confusing. I feel lied to because the commercial made it sound so accessible and easy-to-use.

    I bought this from Indiegogo years ago. I haven't been able to complete one successful project. (With the exception of maybe turning it into a wifi range extender, but I am not entirely sure that worked.) I couldn't even get morse code to work. I even jumped through hoops to figure out the morse code project.

    Then I saw the new firmware update and thought it would be easier to navigate. Unfortunately, I downloaded it and now I'm dead in the water. I can't even restore it because the directions require a serial connection.

    I bit the bullet when my board could no longer use Node Red, and I bit the bullet again when it was no longer cloud connected (which were two huge perks). Granted, it is too much of a pain.

    I think I'm done for now. I might pick it up again, but I don't have the bandwidth right now. Despite my repeated failure I learned a bit.

    Thank you for helping, and I appreciate the community. Since the Onion does have users of all skill levels, my suggestion would be to write (and structure) instructions as if you expect zero programming experience to read it.

    More importantly, please have instructional videos.

  • @Lazar-Demin

    Logged in today, went back to your suggestion. Tried to connect via serial. Did not work. I saw you commented on another post. You asked about the type of onion they had, which helped resolved their issues when connecting via serial. As such, I included pictures of mine below.

    After I download and run the Silicon Labs driver I either get random numbers (not COM 3), or most of the time a caution sign.

    On a side note, as you can see in the photo, the last four of my Onion Omega is 34EB. Since that firmware update it reads (even now) as Omega-34ed.

    Onion Omega 1.jpg Onion Omega 2.jpg

  • Silicon Labs Driver Error.PNG

  • @Amalee Have you tried plugging the USB cable into a different USB port on your computer? My ThinkPad T51 has 3 USB ports, only 1 of them will work with the Omega, however I have the same issue with my Arduino. The USB ports probably have different rating etc, but i never checked. Also check your USB cable. Have you removed the 2 "Unknown Device" from your device manager? They may be using required resources and windoze is just not removing them when you installed the Silicon Lab driver.

  • administrators

    @Amalee The Arduino Dock 2 doesn't have USB-to-Serial - this is mentioned in our docs: http://docs.onion.io/omega2-docs/arduino-dock-2.html#the-microusb-port-4 - which explains why you can't connect thru serial.


    Please try using SSH instead.

    I would also recommend using the stable v0.3.4 firmware (available here http://repo.onioniot.com/omega2/images/) and not the beta firmware. The beta firmware is just that, beta firmware, so you should expect some bumps in the road. You should be able to get up and running easily with the v0.3.4 version.

  • @Lazar-Demin

    Since the ethernet shield fit onto the dock, and lit up, I figured the onion would be able to access the internet via a wired connection.

    Are you saying, despite the shield, ethernet is still not an option?

    If so, how am I supposed to connect to via SSH without access to wifi? (I thought I needed wifi to establish a SSH connection.)

    Is there a wifi driver I can download from a repository?

    If there is no wifi driver to download and I need wifi to connect via SSH, is my onion bricked?

  • administrators

    @Amalee Let's take a step back. Can you explain what exactly you're trying to accomplish?
    Is it to just get the Omega2 up and running?

    The Arduino ethernet shield you have plugged into the Arduino Dock is connected to the ATMega MCU on the Arduino Dock, not the Omega2.
    So that won't help.

    You can connect an Onion Ethernet Expansion if you want ethernet networking.

    Both the stable v0.3.4 and the beta firmware for the Omega2 have working WiFi. And can be accessed by SSH over WiFi, so nothing is bricked.

    If your Omega2 is currently running the stable firmware, you can get to the command-line over SSH by connecting to the WiFi access point hosted by the Omega. See the full details here: http://docs.onion.io/omega2-docs/first-time-setup-command-line.html

    If your Omega2 is currently running the beta firmware, you can follow the same procedure as above. Except when you get to the Provision the Omega’s WiFi step, follow the instructions here: https://github.com/OnionIoT/OpenWRT-Packages/blob/openwrt-22.03/technical-doc.md#sta

    Again, it would help to know what you're trying to accomplish here.

  • @Amalee said in New Firmware, No Wifi, Maybe New Name? Omega2+ 03.2-20230330.bin:

    Firmware: 03.2-20230330.bin

    Yeah, that's all I'm trying to do right now. Get the Onion 2+ back up and running.

    Months ago, I updated the firmware to Firmware: 03.2-20230330.bin

    Assuming I understand correctly, the aforementioned firmware does not have a wireless driver. I did not know that at the time I updated it.

    After putting that firmware's version on it, I have not been able to get my Onion2+ connected to the internet/connected to the SSH, so I can't do anything with it.

    I figured I would flash my Onion back to the previous firmware (or basically any stable firmware).

    After a few attempts, I learned I cannot rollback or update the firmware because the instructions say it requires internet access.

  • administrators

    @Amalee said in New Firmware, No Wifi, Maybe New Name? Omega2+ 03.2-20230330.bin:

    Assuming I understand correctly, the aforementioned firmware does not have a wireless driver. I did not know that at the time I updated it.

    The beta firmware does indeed have a wifi driver. In your OP the screenshots show that you were connected to the Omega's WiFi AP. Then a few posts later, it looks like you disabled the WiFi AP.

    That explains why you can no longer connect to it.

    Follow these steps to get back up and running with the stable firmware:

    1. Do a factory reset (with the reset button) to go back to the default configuration, so the Omega's WiFi AP is running. More info here: http://docs.onion.io/omega2-docs/factory-reset.html#with-the-reset-button-1
    2. On your computer, download the latest v0.3.4-b257 stable firmware from here: http://repo.onioniot.com/omega2/images/
      • Since you have an Omega2+, download the firmware name omega2p-v0.3.4-b257.bin
    3. After the factory restore, connect your computer to the Omega's WiFi AP and connect to the Omega using SSH
    4. Use scp to transfer the firmware downloaded in step 2 to the Omega2. More info here: https://linuxize.com/post/how-to-use-scp-command-to-securely-transfer-files/
    5. On the Omega, use the sysupgrade command to install the firmware. More info here: http://docs.onion.io/omega2-docs/manual-firmware-installation.html#step-2-upgrading-your-omega-to-the-downloaded-firmware

  • @Lazar-Demin I'm completely unfamiliar with command prompts that show if I've successfully restored to the initial version of onion omega software. I made sure to hold the reset button for 10 seconds, and also ran the command:
    firstboot -y
    which did function by turning of the system, but it doesn't make it clear which version I am currently on. Even though I ran a version command block to see if it would even give me the information. And to my surprise it didn't. I tried one last thing to see if it could retrieve the needed assets. With wget http://repo.onioniot.com.s3.amazonaws.com/omega2/images/omega2p-v0.3.4-b257.bin .However, it did not successfully compile it in the screenshot provided along to this thread. retreive-updateimg.png

  • administrators

    @CXP In your case, we're doing a factory restore in order to reset your device to the default configuration where the WiFi AP is on. You can see the version number

    For future reference, you can see the firmware version number in the login banner:

    With regards to the wget command not working, is your Omega connected to the internet through your local wifi network?

    In my previous post, I outlined steps you can follow so that you can avoid connecting the Omega to your local wifi network. Instead you can copy the firmware from your computer directly to the Omega.

  • @Lazar-Demin said in New Firmware, No Wifi, Maybe New Name? Omega2+ 03.2-20230330.bin:

    reference, you can see the firmware version number

    You mentioned in your previous response that I disabled wifi , so I need to reset the onion. I followed that step, and reset it several times. I still cannot get access to wifi. The picture below shows it.

    Thus, it is not connected to our local wifi network (or any wifi network). (There are a couple of us now working on it since this has been a nightmare; got some fresh eyes on it. I explained to my friend the method he took is impossible.)

    Instead, we tried again via USB. 
    Mounted successfully, but we cannot figure out how to get files from the USB to the Onion.
    We got the firmware you suggested onto a USB (omega2p-v0.3.4-b257.bin).
    Successfully mounted the USB.
    Unable to download file from USB to Onion.


  • This post is deleted!

  • This post is deleted!

Looks like your connection to Community was lost, please wait while we try to reconnect.