We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

New Firmware, No Wifi, Maybe New Name? Omega2+ 03.2-20230330.bin

  • Board: Omega2+
    Firmware: 03.2-20230330.bin

    Downloaded the new firmware.

    No Wifi setup
    Ran dmesg --> posted the pictures below
    Don't know what I am looking for

    Side note: After updating the firmware, my onion's name is pseudo changed. As you can see in the picture below, it shows the original name: Omega-34EB (Top Left), but in my wifi network on my laptop it now shows as Omega-34ed.

    Is that normal?

    Pictures Below
    Change in Name, and No Wifi.png

    dmesg P2.png

    dmesg P3.png

  • This post is deleted!

  • administrators

    @Amalee What you're seeing is expected. The new firmware that's based on OpenWRT 22.03 uses the open source mt76 wifi driver and not the wifi-warp-core driver, meaning:

    • You won't see the wifi warp core ascii art in the kernel messages
    • The wifisetup utility is not included in the new firmware - you'll need to use UCI to configure the wifi settings
    • The Omega will no longer automatically switch between known wifi networks

    As an aside: in your first screenshot, you ran /etc/config/network and /etc/config/firewall on the command line and got permission denied errors. This is because /etc/config/network and /etc/config/firewall are configuration files that cannot be executed - you can try opening them using vi.
    If you're looking for the network and firewall service executables (that can be used to start/stop/restart the two services), they are at /etc/init.d/network and /etc/init.d/firewall

    To configure the Omega's wifi connection, follow the instructions here: https://github.com/OnionIoT/OpenWRT-Packages/blob/openwrt-22.03/technical-doc.md#wireless-networking

    The naming change is also unexpected, we'll need to look into that!
    Can you please create an issue using the Bug Report template on github so we can better track this?

  • Hey Lazar,

    Thank you for replying. I followed the instructions in the link.
    The open source mt76 driver is used for wireless networking.

    By default, Omega2 will host an AP (Access Point) network. It will be named Omega-abcd where abcd matches the last four digits of the device’s MAC address

    To disable the AP:

    uci set wireless.default_radio0.disabled='1'
    uci commit wireless

    After the last line Putty freezes, and the Omega refuses to connect for more than a couple of seconds. I reset it a couple of times, and tried same results.

    Then I tried the STA commands, but it says ~ash: wireless not found, and then I tried AP again. It freezes after the last command and refuses to connect for more than a couple of seconds. I eventually get the PuTTY Fatal Error (Network error: Software caused connection to abort).


  • administrators

    @Amalee are you connected to the Omega over SSH or serial?
    If it's SSH, then it's expected the connection will drop after you make changes to the wifi configuration.

    Try connecting through serial and trying again: https://github.com/OnionIoT/OpenWRT-Packages/blob/openwrt-22.03/technical-doc.md#connecting-to-the-device

  • This post is deleted!

  • After a stupid amount of work to get the Onion to popup again in the wifi network bank, and then another stupid amount of work to get the ports turned on in my device manager, after downloading and installing https://www.silabs.com/Support Documents/Software/CP210x_VCP_Windows.zip - it still won't recognize it. I can't connect.

    I can't even get it back to a previous firmware since I need to connect via serial.

    Technically, I have an ethernet shield, but that has not worked.

    The Onion has really soured my experience with development boards.

    Everything from Day 1 all those years ago has been cumbersome and confusing. I feel lied to because the commercial made it sound so accessible and easy-to-use.

    I bought this from Indiegogo years ago. I haven't been able to complete one successful project. (With the exception of maybe turning it into a wifi range extender, but I am not entirely sure that worked.) I couldn't even get morse code to work. I even jumped through hoops to figure out the morse code project.

    Then I saw the new firmware update and thought it would be easier to navigate. Unfortunately, I downloaded it and now I'm dead in the water. I can't even restore it because the directions require a serial connection.

    I bit the bullet when my board could no longer use Node Red, and I bit the bullet again when it was no longer cloud connected (which were two huge perks). Granted, it is too much of a pain.

    I think I'm done for now. I might pick it up again, but I don't have the bandwidth right now. Despite my repeated failure I learned a bit.

    Thank you for helping, and I appreciate the community. Since the Onion does have users of all skill levels, my suggestion would be to write (and structure) instructions as if you expect zero programming experience to read it.

    More importantly, please have instructional videos.

Looks like your connection to Community was lost, please wait while we try to reconnect.