We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

gps receiver not locking

  • I also have the same issue being unable to lock onto a satellite both indoors and outdoors.

  • From the ticket reply I suspect there are lots of users with GPS devices that need to be returned to sender.
    Could just be a small bad batch but I'm guessing at a large batch as they don't make these in one's and two's.

  • Personally after reading the description several times i believe its the red encirceld capacitor which needs to be desoldered.. might just give it a go regardless since the expansion is useless currently anyway...


    0_1486052141470_gps expansion.jpg

  • @Leo-de-Blaauw I would concur but the ticket is far from clear.

    I'm gobsmacked that a supplier even suggests such a fix without first acknowledging they are financially liable for a replacement if the end user is unable to do the suppliers remedial work for them. This includes messing around with the wrong resistor because their instructions are ambiguous.

  • @Costas-Costas true, but in their defence i had a soldering bridge on my omega2+ they have promised to send me a replacement on my ticket for that issue. So went ahead and fixed it and it is working fine now. Replacement not yet here though..

  • I have the same issue. Anybody tried to unsolder the cap yet?

  • I am waiting for a definite response on my support ticket. Will post update when I get one.

  • @Leo-de-Blaauw said in gps receiver not locking:

    Personally after reading the description several times i believe its the red encirceld capacitor which needs to be desoldered.. might just give it a go regardless since the expansion is useless currently anyway...

    No. The description you post appears to be about the capacitor which is already absent from your board.

    Start from Antenna connector to the USB header, the second yellow component is the wrong capacitor.

    That describes something that could have been on the pair of silvery solder-covered pads 2nd in from the antenna connector. Effectively, the proposed rework or change has already been implemented on the board you picture.

    The capacitor you have circled is a much larger one, probably part of a power supply circuit. Removing it is not a good idea.

    However, it's not clear if just having the rework proposed is going to be enough, question would be if the resistor to the right of that is part of the bias supply to the antenna pin, and the removed capacitor was erroneously in parallel with it, or if the capacitor was where the resistor was supposed to be. Some time finding the traces under the soldermask and drawing out the circuit to compare with other published ublox ones could probably solve it, but frustration in being sent non-working hardware is understandable.

    FYI the apparent solder bridge between two ublox pins reflects an apparently intentional connection on at least some schematics that have been published. It's fairly common for a bridge to form between two pads that are already electrically connected, though of course it still catches the eye and is a suspect to investigate when something doesn't work.

  • @Ian-Marchant said in gps receiver not locking:

    From this photo however, I am not 100% sure which part i am supposed to use?


    If that is a picture of your receiver then it's time for an RMA following the comments from Chris Stratton. Or did Onion send you the photo?

  • Hi,

    That is a picture of my board as it arrived from Onion. I have not made any modification at all.

    The only thing I have done to it is to disconnect the antenna and connect an external active antenna. Once the external antenna is connected I get a solid fix with no issues. With the internal antenna... nothing.


  • So you are unable to carry out the remedial work requested by Onion as the rogue capacitor doesn't appear to be there. I would send it back as faulty.

  • Working with an external antenna would not be inconsistent with my suspicions, but those are formed from only a few minutes looking at your picture and a schematic of a different board.

    Anyway, it looks like the suggested rework is already applied, so no use for your soldering iron right now. If you do want to poke at it with tools, you could consider with the system unpowered measuring the resistance between the bridged pair of pins on the module and each side of the white ceramic chip inductor beside the antenna. That is not guaranteeed to be 100% safe for all circuit but is usually tolerated, and could help show if there's an issue with the antenna bias supply.

    I have to stress though that this is all guesses.

  • Hello,

    I have the same issue: unable to lock onto a satellite, indoors and outdoors 😞 . If it's a hardware problem like I understand it in previous posts, I hope there will be a replacement...

  • i got an reply that they aren't going to replace the GPS dock and requires us the customer to unsolder the capacitor saying that "It's not their fault"

    I'm very angry with this situation. anyone else got the same reply and feeling the same ?

  • @dennis-ctp Mine doesnt even have the capicitor and still very very crappy reception if at all both inside and outside..

  • Anybody managed to get the GPS Expansion working?

  • I also have a board like the image @Costas-Costas posted and while i get GPS data via COM port without the VCP Sensor Drivers.. It does not fix location.

    Per this thread I installed the U-Block u-center app and installed the VCP drivers and using their console and app I still am unable to get location and fix.


  • i attached a small indoor antenna, about 3 times the size of the factory one and am able to get a fix which i was not able to do with the factory setup. if the explanation of onion is to be accepted it seems the cap in question dampens the signal to the unit and thus either a better antenna to increase signal or removing the cap to increase signal. the unit pretty much pinpoints exactly where it is, per my experience, once it gets adequate signal.
    edit: i wanted to mention that the antenna i'm using in replacing the factory unit is one off this gps shield board i got a while back. https://www.makerfabs.com/index.php?route=product/product&product_id=133&search=gps+shield
    i think you can pick up one like this for ~$3.

  • My GPS receiver won't lock with the built-in antenna; I connected it to my Pixel phone USB port, started up Droid Term, and immediately saw the NMEA strings - good. However, no fix, just a lot of commas. So then I plugged in my external antenna/LNA and almost immediately got a fix. My board has a blank component location in the second spot from the U.FL connector - if I understand correctly, this is where the capacitor that needs to be removed was and is thus already removed.

    Certainly not useful without a remote antenna - makes me think the built-in antenna is not functioning correctly.

  • Based on what I read here I have an 'updated' unit without the capacitor in location and still not getting a fix on position in any regard.

    Also read that Onion is not taking nor readying replacements admitting the issue yet not taking responsibility.

    Should I just trash this into the failed hardware bin for now or any hope of a response from Onion on this thread and/or placing a ticket?


Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.