We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Defective Hardware (Mini-Dock) | Serial connection not working correctly | Factory Firmware defective

  • It is really embarrassing for me and i guess for a lot of onion.io clients,
    who got hardware who is not working properly.

    • I have to go 9 Mont back, when i observed too that the mini-docks are problematic to connect. Already then, several of us almost got crazy to see /dev/ttyUSB* and to make a serial connection to it.

    • With patient a lot of sacrifice and spending money buying several USB Cables, I am begging onion.io to take some actions now an solve this problem.

    • With the onion1 i could more or less working. I had to plug in out several times the cable till i finally could see /dev/ttyUSB* and connect to it.

    • With Omega2+ and the mini docks I do have no chance to get it working.
      Because of helping out here in the Forum i got the privilege to choose 3 different docks.

    With the Ethernet-dock and the big-dock I had chosen then, I was finally able to install a actual firmware (omega2p-v0.1.9-b149.bin). I have chosen b149 because the Repository still is based on that, to avoid any other complications.

    • With a actualized driver fixed firmware on my Omega2+ i went back to the mini docks (yes plural, i tested both) and:

    • Reset button is still not working !

    • screen and cu software are just get in to sleeping mode

    • no interaction with omega2+ possible (keyboard not response even if i could see the boot log). SSH also not works.

    Now my big Quiz question to omega.io and their @administrators :

    • How does a 0-8-15 (common) user has to proceed without a alternative to other docks (big&Ethernet) ??

    Interaction with Omega and Keyboard not possible.

    [   11.279809] usbhid: USB HID core driver
    [   11.287400] usbcore: registered new interface driver usblp
    [   11.301409] usbcore: registered new interface driver usbserial
    [   11.307441] usbcore: registered new interface driver usbserial_generic
    [   11.314245] usbserial: USB Serial support registered for generic
    [   11.332749] Driver for 1-wire Dallas network protocol.
    [   11.359089] xt_time: kernel timezone is -0000
    [   11.365830] usbcore: registered new interface driver ch341
    [   11.371600] usbserial: USB Serial support registered for ch341-uart
    [   11.380407] usbcore: registered new interface driver cp210x
    [   11.386180] usbserial: USB Serial support registered for cp210x
    [   11.395744] usbcore: registered new interface driver ftdi_sio
    [   11.401804] usbserial: USB Serial support registered for FTDI USB Serial Device
    [   11.423887] usbcore: registered new interface driver pl2303
    [   11.429765] usbserial: USB Serial support registered for pl2303
    [   11.441265] PPP generic driver version 2.4.2
    [   11.448891] NET: Registered protocol family 24
    [   11.466868] usbcore: registered new interface driver snd-usb-audio
    [   11.484022] usbcore: registered new interface driver uvcvideo
    [   11.489923] USB Video Class driver (1.1.1)
    [   12.071341] random: jshn: uninitialized urandom read (4 bytes read, 21 bits of entropy available)
    [   12.180853] random: ubusd: uninitialized urandom read (4 bytes read, 21 bits of entropy available)
    [   19.861545] device eth0.1 entered promiscuous mode
    [   19.866423] device eth0 entered promiscuous mode
    [   19.881926] br-wlan: port 1(eth0.1) entered forwarding state
    [   19.887732] br-wlan: port 1(eth0.1) entered forwarding state
    [   21.878455] br-wlan: port 1(eth0.1) entered forwarding state
    [   77.968499] random: nonblocking pool is initialized

    in System monitor of my LMDE it says the process (there are two) is sleeping.

    Mini-Dock back and front side:






  • @Luciano-S. ... Luciano, I agree that the Mini Docks serial connection isn't working with the Omega2s. In fact I posted about it here two weeks ago. My experiences may be a bit different; my year-old Mini docks do work well with Omega1. With Omega2, my PCs receive serial OK, but CANNOT TRANSMIT serial (ie via the RX0 pin) to the Omega2, so I cannot DO anything on the Omega2 with serial communication. A few people responded and basically agreed with my post. Frankly, I am amazed that more didn't say "Me, too", as I have found serial connection to be indispensable to learning and diagnosing (usually self-inflicted) problems in this gear.

    The difference in how our computers fail to communicate via serial - is this a difference in how Linux handles the lack of a valid PC-to-Dock communication? In my case, Windows 7 seems to tolerate Mini Dock-to-PC without PC-to-Mini Dock communication.

    Clearly, my issue is not a Windows serial set-up or Putty problem, as this bi-directional communication works fine with my Omega1s, with a direct wired USB UART connection to an Omega2, or with the Omega2s in the Expansion Dock.

    How is it that all the Mini docks that I received in three orders shipped in early 2016 don't have working serial RX0 with the Omega2? Sure would like to use these Mini Docks .... I am primarily developing for portable and remote uses.

    I looked at the Onions Mini Dock schematic. I found that our mini docks are not the same as shown in the design - I do not see a 3K resistor from PC TXD to ground on your or my docks ... I believe the purpose of this resistor would be to take a floating signal low. I tried soldering a 3K resistor there, to learn that I can't reliably solder with these tiny components!!

    In the Mini and Expansion docks I measured and compared the bare (ie without Omegas), USB-cord-powered voltages to ground, to find that the RX0, TX0 and FW RST sockets DO respectively have DIFFERENT voltages. Based on this preliminary testing, I would conclude there is a difference in how the Omega1 and Omega2 communicate via serial RX0 and Tx0, since both work with the 2015 designed Expansion Dock, only the Omega1 (at least with MS Windows) works with the 2015 designed Mini Dock.

    Again, I challenge anyone reading this to reply that their "Mini Dock (of any vintage) works fine with the Omega2 or Omega2+ via a serial connection" as described here- Terminal connection to Omega via serial . We need these docks and I for one welcome learning how to make it work.

  • same problem.
    in my case, I suspect using the minidock even bricked my omega2+

  • @dennis-ctp said in Defective Hardware (Mini-Dock) | Serial connection not working correctly | Factory Firmware defective:

    same problem.

    I guess you talk about the serial connection freezing? Your flooding of @ characters?
    I got strange characters once when i tried connect with a wrong speed (omega1).

    in my case, I suspect using the mini-dock even bricked my omega2+

    Bricking means "unusable" in sens of software not working anymore. But normally there is a process to fix that. As the omega comes already with a factory firmware not working correctly, and the problem with an incompatible mini-dock, you are not able to fix that.

    Your solutions:

    • buy a normal dock
    • buy a Ethernet dock
    • buy a alternative mini dock
    • or just actualize your profile that users can see in which region you live, maybe someone close to you offers to help out fix it. (you could also ask for help in a new request)
    • or just wait till someone contacts you from onion.io and gives you an RMA.

  • @Ken-Conrad I just noticed your post and yes, it looks like the mini-dock does not, indeed, match the schematics on Onion's github-repo; on the schematics there are two 3k pull-down resistors on the UART-lines, but I don't even see a 3k resistor at all on the mini-dock in the picture here. I see six 1k resistors and one 10k resistor. That doesn't match any of the schematics. Are there more resistors that aren't visible in the picture?

  • @WereCatf Yes, thanks for reading my post. Luciano's photos of the Mini dock are good and I have the same docks. Yes, there is not a 3K resistor on my docks.

    Back when I was fussing with them, I was astonished that at direct connection of a UART (3 wires RX, TX and Gnd, if have separate 3V3 power) or four wires from a good 3V3 UART to the Omega2 works fine with bi-directional communication, but these docks fail on the (Omega) RX0 line, every time. That's why I asked what is the hardware fix ... replace the TX and RX 1,000 ohm resistors with 0 ohm or is there another pin in the wrong state? I don't have my notes here, but I think I also found on my working Expansion dock that the TX0 socket is at 0V, on the Mini dock it is ~3.3V - I'll check later to confirm. Could there be something screwy with the beginning state of the onboard UART?

    I'd guess someone in 2016 did a revision or production change to these Docks. If your Mini dock works please post detailed photos of the top and bottom so we can see if you have a 3,000 ohm resistor or other chips.

  • @WereCatf By the way, I've been meaning to write you about this - In regard to your dock design and since we have these nice photos of the Onion Mini Dock, and assuming that you don't own a Mini Dock ... do take a look at Onion's arrangement of the Type A USB socket, set up so there is ample clearance between it and the bottom of the Omega board - accomplished by using a bit unusual 'low-rider' USB socket with solder pads on the sides and cutting a hole in the circuit board to recess the socket a bit! In the case of the Omega2 on your board, is the worst case a standard USB socket grounding out against ... ?

  • @Ken-Conrad The low-profile USB Type-A sockets are harder to find and thus more expensive than the regular kind. I could've designed my board with those, but I wanted to use components that are very easy and cheap to source.

  • @Ken-Conrad About the mini-dock: I have an external CP2104-based USB-TTL, with no pull-up/pull-down resistors at all, which works perfectly well and fine with the Omega2. This leads me to believe that if there is a pull-down resistor on the mini-dock on UART0_RX, it is possibly the reason why it's not working. I suppose you could try poking around with a multimeter, until you find the pull-down resistor and then removing it.

  • as long as we are talking defective hardware lets give a big shout out to the gps expansion. onion admits a fault in the unit and at the same times claims it's not their fault. yes, according to another poster onion claims gps expansion faults that they admit exist are not their fault. so good luck with the mini dock. i can confirm though that the expansion dock has a good serial connect if that interests you at all.

  • @Douglas-Kryder Well, are you talking about the old expansion-dock for the Omega1, or the newer one for the Omega2? And if you're talking about the old one, does it match with the schematics at https://github.com/OnionIoT/Onion-Hardware/blob/master/Schematics/Omega-Expansion-Dock.pdf ? The Omega1 mini-dock these guys have doesn't match the schematics, so that's a problem.

  • @WereCatf i was talking about the one released with the omega2 group of products.

  • OK, i made a ticket for the onioneers i will give feedback when i get ...
    #5898 freshdesk ticket.

  • The answer from Onion:

    There was problems with resistor in serial circuit of old mini dock. But it works with Omega1. Since we never promise compatibility between old mini dock and new Omega2, there is nothing we can do about this. If you want to use Omega 2 with mini dock, I suggest that you can buy a mini dock 2 to solve this problem.

    @administrators @onion
    You also never told us that you sell us broken hardware for the full price!
    Big Buuuuu for onion.io!

  • And by the way, i was mentioning my problems i also had with the Omega1 setup and my mini-docks. I had to change hardware that i see the dock permanent when it is plugged in over USB.


    Onion.io just ignores such facts, not responding on question ppl make here or just do so if everything would be ok.

    A normal client without a lot of technical readings knowledge just assumes that there is one version of a mini-dock ... a working , free of bugs, on.

    At least when he is paying 15.- Dollars and about 70% taxes on it (x2) !!

    The schematic show clearly one version of mini-dock ... the working one ! and compatible with omega2/2p

    It is really easy, the stupid client is always the one who is the idiot!

  • @Luciano-S.
    How did you take this excellent photo (what kind of apparate, settings) please?
    If I understand well there can be at least two (or three?) Minidock versions. Which one is this?

    Thank you in advance for your answer,

  • Firstly I'm partly sorry for reviving the old thread; but I've butted my head against this same problem.

    @onion can you fix your documentation so we can track these changes and make the necessary adjustments to our boards? Suggesting simply buying the mini dock 2 when there is no such item for sale isn't making this any less frustrating. I must admit I had completely forgotten about these things until I was looking to replace Hi-link RM04 modules, their next model was pretty much identical and I saw an opportunity to get my work to support the open source community ... but when I couldn't even get a serial connection going after an hour the powers to be pulled the plug. However I'd still like to sort this out for my own use.

    I borrowed the rewards from a friend who also backed the 2 and 2+ and his dock is identical to mine. Neither work.

  • @bearer The Omega-Mini-Dock schematic is basically correct. This can be the version2 board with original Omega header pinout (U5). For Omega2(+) one should replace U5 to a correct header pinout and change RXD, TXD to RX0, TX0 respectively.
    There are no TVS diodes (D12, D13, D14) on the Minidock.

    Only these are the hardware differences between the Minidock versions:

    R77, R83, R84 are 1 kOhm SMD resistors (marking 102) on the v1 board
    R77, R83, R84 are 3 kOhm SMD resistors (marking 302) on the v2 board

    Minidock version1 (photo by @Luciano-S)

    To fix the problems of the Minidock version1 board is fairly simple:

    1. remove / desolder the R77, R83 and R84 resistors - IMHO this is the best solution 🙂
    2. or solder a 0 Ohm (or a piece of wire) to the top of the R76, R81 and R82 resistors (ie. replace them with 0 Ohm)
    3. or change R77, R83 and R84 1 kOhm to 3 kOhm (so you'll have a genuine version2 Minidock 😉

    I hope all above info are correct but - as usual - make these modifications at your own risk.
    Good luck!

    Do you want further background info?

  • Thanks for the detailed reply. I went with option 3 and managed to fit some 0805 onto the 0603 pads and it works as expected. Thanks again.

Looks like your connection to Community was lost, please wait while we try to reconnect.