We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2+ Wifi unstable and slow

  • Hello everyone,

    I've taken my omega2+ out of the shelf and I'm having a weird issue now.
    I am able to connect to Wifi, but once connected the connection is really unstable, will still be connected to my wifi router but won't be able to contact any server.

    Sometimes I have 20s were everything is fine (usually just after connecting to the rooter) and then nothing. I can't even access the web based interface. Serial is working fine, here is what I got when I try to ping google.fr:

    root@Omega-4305:/# ping google.fr
    PING google.fr ( 56 data bytes
    64 bytes from seq=0 ttl=55 time=37.901 ms
    64 bytes from seq=1 ttl=55 time=49.629 ms
    64 bytes from seq=2 ttl=55 time=115.104 ms
    64 bytes from seq=5 ttl=55 time=25.481 ms
    64 bytes from seq=4 ttl=55 time=1025.922 ms
    64 bytes from seq=12 ttl=55 time=1060.664 ms
    64 bytes from seq=13 ttl=55 time=62.044 ms
    64 bytes from seq=14 ttl=55 time=79.197 ms
    64 bytes from seq=15 ttl=55 time=41.938 ms
    64 bytes from seq=16 ttl=55 time=94.022 ms
    64 bytes from seq=17 ttl=55 time=1590.211 ms
    64 bytes from seq=19 ttl=55 time=65.239 ms
    64 bytes from seq=22 ttl=55 time=2785.021 ms
    64 bytes from seq=29 ttl=55 time=94.102 ms
    64 bytes from seq=28 ttl=55 time=1096.048 ms
    --- google.fr ping statistics ---
    31 packets transmitted, 15 packets received, 51% packet loss
    round-trip min/avg/max = 25.481/548.168/2785.021 ms

    And here I'm lucky when I dont get a

    ping: bad address 'google.fr'

    All other devices on this network work perfectly fine. Do you have any idea? I was using 0.2.2 version of the OS and updated to the last one but the issue is still here.


  • @Alexy-Torres it might be better to ping the local router if you want to pin bad network traffic on the omega2+. reason being without the hops being shown on the ping to google it's a leap of faith to accept that the onion is the bad hop.

  • You are completly right ahah,
    here are the result when I ping my router:

    root@Omega-4305:~/DomoHome/OmegaWebServer# ping
    PING ( 56 data bytes
    64 bytes from seq=3 ttl=64 time=2140.563 ms
    64 bytes from seq=4 ttl=64 time=1141.855 ms
    64 bytes from seq=6 ttl=64 time=98.246 ms
    64 bytes from seq=7 ttl=64 time=30.148 ms
    64 bytes from seq=8 ttl=64 time=30.203 ms
    64 bytes from seq=9 ttl=64 time=25.562 ms
    64 bytes from seq=10 ttl=64 time=13.283 ms
    64 bytes from seq=11 ttl=64 time=28.967 ms
    64 bytes from seq=12 ttl=64 time=20.664 ms
    64 bytes from seq=13 ttl=64 time=24.341 ms
    64 bytes from seq=14 ttl=64 time=32.039 ms
    64 bytes from seq=15 ttl=64 time=39.736 ms
    64 bytes from seq=16 ttl=64 time=23.557 ms
    64 bytes from seq=17 ttl=64 time=35.133 ms
    64 bytes from seq=18 ttl=64 time=18.750 ms
    64 bytes from seq=19 ttl=64 time=27.330 ms
    64 bytes from seq=20 ttl=64 time=14.212 ms
    64 bytes from seq=21 ttl=64 time=29.913 ms
    64 bytes from seq=22 ttl=64 time=33.677 ms
    64 bytes from seq=23 ttl=64 time=18.044 ms
    64 bytes from seq=25 ttl=64 time=1101.344 ms
    64 bytes from seq=27 ttl=64 time=148.011 ms
    --- ping statistics ---
    31 packets transmitted, 22 packets received, 29% packet loss
    round-trip min/avg/max = 13.283/230.708/2140.563 ms

    I'm 1 metter away from the wifi router

  • @Alexy-Torres @Douglas-Kryder I would be interested to know what your wifi configuration is.

    I would also run another test. Place your Omega next to the wifi router you are connected to and try ping again. I have found that some of my Omega2+ seem to be effected by some interference, I think it is my B&O TV but not sure. When I move the Omega away from that TV they work just fine. I can take the same Omega to my office and it works perfectly anywhere in my office. Not sure if this is your issue but I think it is worth looking at.

  • @crispyoz Thanks for the reply!

    Do you have a specific command in mind? I also put the omega right next to the router and get the same result. I also tried connecting the omega to my cell phone AP and get the same issue.

    Here are my wifi settings:

    config wifi-device 'radio0'
            option type 'ralink'
            option variant 'mt7628'
            option country 'US'
            option hwmode '11g'
            option htmode 'HT40'
            option channel 'auto'
            option disabled '0'
            option device_mode 'apsta'
            option op_mode 'preference'
    config wifi-iface 'ap'
            option device 'radio0'
            option mode 'ap'
            option network 'wlan'
            option ifname 'ra0'
            option encryption 'psk2'
            option key '12345678'
            option disabled '0'
            option ssid 'Omega-4305'
    config wifi-iface 'sta'
            option device 'radio0'
            option mode 'sta'
            option ifname 'apcli0'
            option encryption 'psk2'
            option network 'wwan'
            option disabled '0'
            option ssid 'Torres 2.4GHz'
            option key 'REDACTED'
            option led 'omega2p:blue:wifi'
    config wifi-config
            option ssid 'Torres 2.4GHz'
            option encryption 'psk2'
            option key 'REDACTED'
    config wifi-config
            option ssid 'AlexyAPS'
            option encryption 'psk2'
            option key 'REDACTED'

  • @Alexy-Torres That looks pretty normal. My first thought is that it seems some users have had issues with their wifi due to some differences with US configuration. Try removing "option country ''US"

  • @crispyoz I tried that but unfortunately I still have the same results. If that could help someone, the issue appeared like 3 days ago and wasn't present 1 week ago.

  • @Alexy-Torres that is interesting. It suggests something has changed. If this happened to me I would do as follows:

    1. Factory reset
    2. Use wifisetup to configure wifi
    3. oupdate

  • @crispyoz I already did. At first I factory reset the omega, then updated the firmware (that was a pain in the ass with this connection issue ahah) and nothing changed.

  • @Alexy-Torres How are you powering your Omega?

  • @crispyoz Through the dock, plugged by USB on my computer, I also tried to plug it to a usb charger directly

  • Just an update, I used the omega today and everything was fine, I don't know what happened...

  • @Alexy-Torres Something I noticed is that the AP mode is using the same channel as my home router so big and random interference might happen from time to time.

    Can you check with any wifi scanner if the AP wifi or your Onion is using the same channel as your home router?


  • Any further updates? This always happens to me from time to time. Sometimes it just resolves itself after I do a full power off and on.

Looks like your connection to Community was lost, please wait while we try to reconnect.