We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2S+: No WiFi Support with OpenWRT 21.02


  • administrators

    @IBH Vanilla OpenWRT isn't configured for easy networking right out of the box, you'll have to make network, firewall, and wireless configuration changes.

    Take a look at our UCI-defaults network configuration script for an idea of what we do:
    For an idea of how we configure the beta OpenWRT 22.03 firmware, take a look at UCI-defaults network configuration script:https://github.com/OnionIoT/OpenWRT-Packages/blob/openwrt-22.03/omega2-base/files/etc/uci-defaults/15_network

    Alternatively, you can use our beta OpenWRT 22.03 firmware. It supports wifi networking right out of the box. More info in this thread: https://community.onion.io/topic/4963/beta-openwrt-22-03-firmware-available-your-feedback-is-needed

    EDIT: specified UCI defaults are for OpenWRT 22.03



  • @Lazar-Demin Hi Lazar, I'm using the OpenWRT 21.02 release and not the onion openwrt. I did the configuration shared by @crispyoz in the forum :

    https://community.onion.io/topic/4940/original-image-openwrt-22-03-3-ramips/2?_=1680610145788

    And I got an issue related to the interface radio0 doesn't exist. Maybe I missed something and for this reason I would like to check with you both.


  • administrators

    @IBH Ah my mistake, I didn't specify the uci defaults configuration is for our new beta firmware that's based on OpenWRT 22.03. This should apply to your situation since this firmware also uses the mt76 wifi driver.



  • @IBH Here is my OpenWrt 21 config:

    root@OpenWrt:/etc/config# cat network
    config interface 'loopback'
            option device 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd25:0766:cc06::/48'
    
    config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '0'
    
    config interface 'wwan'
            option proto 'dhcp'
            option device 'apcli0'
    
    config interface 'wlan'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
            option type 'bridge'
    
    
    cat wireless
    
    config wifi-device 'radio0'
            option type 'mac80211'
            option path 'platform/10300000.wmac'
            option channel '11'
            option band '2g'
            option htmode 'HT20'
            option disabled '0'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'wlan'
            option mode 'ap'
            option ssid 'OpenWrt'
            option encryption 'none'
    
    config wifi-iface 'sta'
            option device 'radio0'
            option mode 'sta'
            option network 'wwan'
            option ifname 'apcli0'
            option ssid 'MYSSID'
            option encryption 'psk2'
            option key '*********************************'
    
    


  • @crispyoz Thank you , I did a ' wifi up' but the status says it is not up. Any help please ? How do you run those configs ?

    root@OpenWrt:/# wifi status
    {
            "radio0": {
                    "up": false,
                    "pending": true,
                    "autostart": true,
                    "disabled": false,
                    "retry_setup_failed": false,
                    "config": {
                            "path": "platform/10300000.wmac",
                            "channel": "11",
                            "band": "2g",
                            "htmode": "HT20",
                            "disabled": false
                    },
                    "interfaces": [
                            {
                                    "section": "default_radio0",
                                    "config": {
                                            "mode": "ap",
                                            "ssid": "OpenWrt",
                                            "encryption": "none",
                                            "network": [
                                                    "wlan"
                                            ],
                                            "mode": "ap"
                                    },
                                    "vlans": [

    ],
                                    "stations": [

    ]
                            },
                            {
                                    "section": "sta",
                                    "config": {
                                            "mode": "sta",
                                            "ifname": "apcli0",
                                            "ssid": "MYSSID",
                                            "encryption": "psk2",
                                            "key": "*********************************",
                                            "mode": "sta",
                                            "network": [
                                                    "wwan"
                                            ]
                                    },
                                    "vlans": [

    ],
                                    "stations": [

    ]
                            }
                    ]
            }
    }



  • @IBH Your configuration is using my dummy wifi ssid and key so that isn't going to work on your wifi. You need to update the configuration to utilise your wifi.

                "ssid": "MYSSID",
                                            "encryption": "psk2",
                                            "key": "*********************************",
    

    To search for available wifi, use this command iw dev apcli0 scan | grep -i ssid

    To update the ssid and key you can either edit the file /etc/config/wireless or use these commands:

    uci set wireless.sta.ssid='<ENTER YOUR SSID HERE>'
    uci set wireless.sta.key='<ENTER YOUR WIFI PASSWORD HERE>'
    uci commit wireless
    service network restart



  • @crispyoz
    I got this:
    root@OpenWrt:/# iw dev apcli0 scan | grep -i ssid
    command failed: No such device (-19)
    Do I miss something?
    I do not need it to connect to a network. I need it to provide one.
    When I did wifi up the radio0 doesn't be up and I cannot see the ssid on my phone.



  • @crispyoz this is the output of lsmod:
    root@OpenWrt:/# lsmod
    cfg80211              286959  3 mt7603e,mt76,mac80211
    compat                  1346  2 mac80211,cfg80211
    crc_ccitt               1774  0
    gpio_button_hotplug     7058  0
    ip_tables              10275  2 iptable_mangle,iptable_filter
    ip6_tables             10087  2 ip6table_mangle,ip6table_filter
    ip6t_REJECT             1298  0
    ip6table_filter          754  0
    ip6table_mangle         1234  0
    ipt_REJECT              1234  0
    iptable_filter           722  0
    iptable_mangle           978  0
    leds_gpio               3058  0
    mac80211              534529  2 mt7603e,mt76
    mmc_block              27130  0
    mmc_core               91816  2 mmc_block,mtk_sd
    mt76                   40830  1 mt7603e
    mt7603e                39804  0
    mtk_sd                 15170  0
    nf_log_common           3000  2 nf_log_ipv4,nf_log_ipv6
    nf_log_ipv4             3602  0
    nf_log_ipv6             4274  0
    nf_reject_ipv4          2313  1 ipt_REJECT
    nf_reject_ipv6          2670  1 ip6t_REJECT
    nls_base                5354  1 usbcore
    ohci_hcd               24424  1 ohci_platform
    ohci_platform           3442  0
    usb_common              3134  2 ohci_hcd,usbcore
    usbcore               144625  2 ohci_platform,ohci_hcd
    x_tables               16295 17 ipt_REJECT,xt_time,xt_tcpudp,xt_multiport,xt_mark,xt_mac,xt_limit,xt_comment,xt_TCPMSS,xt_LOG,iptable_mangle,iptable_filter,ip_tables,ip6table_mangle,ip6table_filter,ip6_tables,ip6t_REJECT
    xt_LOG                   818  0
    xt_TCPMSS               3218  0
    xt_comment               562  0
    xt_limit                1394  0
    xt_mac                   690  0
    xt_mark                  722  0
    xt_multiport            1362  0
    xt_tcpudp               1874  0
    xt_time                 1970  0



  • @crispyoz
    root@OpenWrt:/# iw list
    Wiphy phy0
            wiphy index: 0
            max # scan SSIDs: 4
            max scan IEs length: 2257 bytes
            max # sched scan SSIDs: 0
            max # match sets: 0
            Retry short limit: 7
            Retry long limit: 4
            Coverage class: 0 (up to 0m)
            Device supports AP-side u-APSD.
            Device supports T-DLS.
            Available Antennas: TX 0x1 RX 0x1
            Configured Antennas: TX 0x1 RX 0x1
            Supported interface modes:
                     * IBSS
                     * managed
                     * AP
                     * AP/VLAN
                     * monitor
                     * mesh point
                     * P2P-client
                     * P2P-GO
            Band 1:
                    Capabilities: 0x17e
                            HT20/HT40
                            SM Power Save disabled
                            RX Greenfield
                            RX HT20 SGI
                            RX HT40 SGI
                            RX STBC 1-stream
                            Max AMSDU length: 3839 bytes
                            No DSSS/CCK HT40
                    Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                    Minimum RX AMPDU time spacing: No restriction (0x00)
                    HT TX/RX MCS rate indexes supported: 0-7
                    Frequencies:
                            * 2412 MHz [1] (14.0 dBm)
                            * 2417 MHz [2] (14.0 dBm)
                            * 2422 MHz [3] (14.0 dBm)
                            * 2427 MHz [4] (14.0 dBm)
                            * 2432 MHz [5] (14.0 dBm)
                            * 2437 MHz [6] (14.0 dBm)
                            * 2442 MHz [7] (14.0 dBm)
                            * 2447 MHz [8] (14.0 dBm)
                            * 2452 MHz [9] (14.0 dBm)
                            * 2457 MHz [10] (14.0 dBm)
                            * 2462 MHz [11] (14.0 dBm)
                            * 2467 MHz [12] (14.0 dBm) (no IR)
                            * 2472 MHz [13] (14.0 dBm) (no IR)
                            * 2484 MHz [14] (14.0 dBm) (no IR)
            valid interface combinations:
                     * #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 4,
                       total <= 4, #channels <= 1, STA/AP BI must match
            HT Capability overrides:
                     * MCS: ff ff ff ff ff ff ff ff ff ff
                     * maximum A-MSDU length
                     * supported channel width
                     * short GI for 40 MHz
                     * max A-MPDU length exponent
                     * min MPDU start spacing
            max # scan plans: 1
            max scan plan interval: -1
            max scan plan iterations: 0
            Supported extended features:
                    * [ RRM ]: RRM
                    * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                    * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                    * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                    * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
                    * [ AQL ]: Airtime Queue Limits (AQL)
                    * [ SCAN_RANDOM_SN ]: use random sequence numbers in scans
                    * [ SCAN_MIN_PREQ_CONTENT ]: use probe request with only rate IEs in scans
                    * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
                    * [ DEL_IBSS_STA ]: deletion of IBSS station support
                    * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
                    * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support



  • @crispyoz root@OpenWrt:/# iw dev
    phy#0
            Interface wlan0
                    ifindex 5
                    wdev 0x2
                    addr 40:a3:6b:c3:17:1f
                    type AP
                    txpower 14.00 dBm
                    multicast TXQ:
                            qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                            0       0       0       0       0       0       0       0               0



  • @IBH Strange, everything looks correct to me, but iw status does not show the SSID. After you made changes to the wireless file, try rebootig and wait for a minute before running wifi status. Also try making these changes:

    uci set wireless.radio0.channel='auto'
    uci set wireless.sta.disabled='1'
    uci commit wireless

    Then reboot.



  • @crispyoz I've tried that too but still no luck 😞


  • administrators

    @IBH Maybe try using the 21.02 firmware released by OpenWRT: onion_omega2p-squashfs-sysupgrade.bin at https://downloads.openwrt.org/releases/21.02.5/targets/ramips/mt76x8/

    If the wifi works using that firmware, then it points to an issue with the customized firmware you've built.



  • @IBH I put my firmware binary on my github, you just need to add the wifi configuration I posted earlier. If that works for you I can share my build config. If the Onin version works for you as provided by @Lazar-Demin go with that one as mine is based up on the standard OpenWrt build.



  • @crispyoz Thank you , we are using same as you an Openwrt build and we don't use onion-openwrt . Will check with your firmware binary and @Lazar-Demin's firmware too. In fact, it is strange that we have the wlan interface and everything looks good but we couldn't see the SSID and have the connection.



  • @IBH I wonder if you tried treating the AP WiFi SSID as hidden and connect manually. Your WiFi command shows he SSID is not configured as hidden but it's just a thought. Anyway we know my config works on my build so the answer is there somewhere.

    Looking at the bigger picture, you probably should be using OpenWrt 22 anyway.



  • @crispyoz Do you know how we can verify if the AP WiFi SSID was treating as hidden ?
    For OpenWrt 22, which tag you used for the upgrade from 21 to 22? does it openwrt-22.03 ?



  • @IBH Looking at the output of your "wifi status" command I can see the SSID is not configured to be hidden, I was just pondering if the issue was related to something on your build that caused it to be hidden.

    For OpenWrt 22 I used "openwrt-22.03"



  • Hi @crispyoz, wifi works fine with your build image :MicrosoftTeams-image (17).png
    Could you please tell me if you have rebased the branch openwrt-22.03 into your branch ? Could you please share the steps you have done for upgrading your openwrt build ?

    THank you so much for your time and help.



  • @IBH I don't rebase. Just a git clone, then make menuconfig make kernel_menuconfig add my changes to uci defaults and files directories then make.



Looks like your connection to Community was lost, please wait while we try to reconnect.